1
$\begingroup$

I make GFX on a game called Roblox, and today I was making one but when I rendered it, the render didn't have the texture on it. It still has the texture on it in 3D View though.enter image description here Please help because I cannot find a solution anywhere online and I have tried most things and it still doesn't have the texture on in the render, even though it does it 3D View.

$\endgroup$
  • $\begingroup$ Can you provide the blend file? $\endgroup$ – Francisco Arleo Dec 26 '18 at 17:20
  • $\begingroup$ I don't know how to sorry. $\endgroup$ – Edwin Stojanov Dec 26 '18 at 17:32
  • $\begingroup$ Don't worry about it, just go to this url blend-exchange.giantcowfilms.com , drag and drop your file and then paste this question's url below $\endgroup$ – Francisco Arleo Dec 26 '18 at 17:34
  • $\begingroup$ Okay I did. You can find it at the end of my question. $\endgroup$ – Edwin Stojanov Dec 26 '18 at 17:42
  • $\begingroup$ You forgot the texture images, you can pack them in the blend by going to File > External Data > Automatically pack into .blend $\endgroup$ – Francisco Arleo Dec 26 '18 at 17:56
3
$\begingroup$

Assuming your texture is an image file this should work.

Change it from Blender Render to Cycles Render. enter image description hereGo into edit mode(tab-key) and unwrap it(u-key). enter image description hereGo into the node editorenter image description here. In the node editor bring up the node add menu (shift + a), and select image texture. Assign your image/texture to the image texture boxenter image description here. Attach the yellow node from the texture image box to the diffuse box.enter image description here. This should work.

$\endgroup$
  • $\begingroup$ Before visiting the Node Editor panel, is it necessary to go to Properties panel -> Material and click Use Nodes? $\endgroup$ – unutbu Dec 27 '18 at 1:30
  • $\begingroup$ It is necessary to enable nodes. Like you suggested, you can do that in the material panel, but you can also do it when you open the nodes editor. There should be a check box at the bottom of the editor that you can click to enable it. $\endgroup$ – Brian T Brennglass Dec 27 '18 at 1:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.