1
$\begingroup$

I have a Mac Book Pro (High Sierra 10.13.6), with an Intel I7 processor and an NVIDIA GeForce GT 750M Graphics card with the very latest drivers installed. My problem is that when I look at the Systems tab in Blenders preferences I cannot see any mention of CUDA under the 'cycles compute device'. My graphics card is there with a ticked checkbox, but I just have a 'None' or 'OpenCL' option above that. How do I get the CUDA option to appear, so that I can use my GPU to render instead of my CPU?

$\endgroup$
6
  • $\begingroup$ What happens if you choose OpenCL? Does that work? $\endgroup$ Dec 24 '18 at 22:00
  • $\begingroup$ Fairly certain that's been a known issue in Blender for a long time. OpenCL is the only option available across all Macs so far as I know. I think it might actually be Apple's fault, but I'm not sure. $\endgroup$ Dec 25 '18 at 0:21
  • $\begingroup$ Do you have CUDA drivers installed with the nVidia Web driver? That was how I got it to work. $\endgroup$ Dec 25 '18 at 7:32
  • $\begingroup$ Hi Dale, I'm not sure that I'm getting anything from the OpenCL option, but then I don't know what to look for! I can use Cycles in the same way I can on my PC, but so far I'm stuck with CPU rendering. $\endgroup$
    – Jim Coote
    Dec 29 '18 at 13:57
  • $\begingroup$ Hi Samir, I've tried CUDA drivers from several sources including those downloaded from NVIDIA. I've now got the NVIDIA Driver manager installed. I would have hoped that using this would automatically ensure I was selecting the very best driver possible. Maybe I'm being naive! $\endgroup$
    – Jim Coote
    Dec 29 '18 at 14:01
1
$\begingroup$

Blender doesn't support gpus on Mac, I own a Macbook with Radeon 555x gpu and i7 - 9750H, and it can't render on gpu

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.