1
$\begingroup$

This question already has an answer here:

I have a lot of materials and textures in my scene that I don't use, but idk how to delete them. Could someone help me and tell me how to do that? 'Cause it eats up a lot of memory and crashes (._. ) Every time I import an object it creates a few copies of the same material\texture, for some reason...

enter image description here

$\endgroup$

marked as duplicate by Duarte Farrajota Ramos, Leander, Martynas Žiemys, Ray Mairlot, gandalf3 Dec 26 '18 at 13:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1
$\begingroup$

If you go to the outliner and set the mode to "blend file" you can control the contents of the blend file. (And remove textures, materials etc if they are not in use at the moment)

For the issue of multiplication when importing I would really go through the import settings and make sure that you aren't importing materials/textures, and then just recreate the shading in blender after import.

$\endgroup$
  • $\begingroup$ There's no delete option, and I can't unlink either, it says ''not implemented yet''. It's not in the orphan tab either, probably is still used by some materials, but idk which, none of them marked with 0 users although I'm pretty sure none of the objects are using them.. Is there a way to find out which material uses a certain texture? ('cause imported items all have different named materials and it's a mess xD) $\endgroup$ – CupOfRedTea Dec 24 '18 at 9:19
  • $\begingroup$ Are you sure you have the outliner set to "blend file" mode? Even if I had texture being used in a material I could remove it with right click-delete in the blend file view of outliner (In 2.79b and 2.80) The "not implemented yet" sounds weird what version of blender are you using? EDIT: as for figuring out which textures are tied to which materials I sadly don't know of a way to visualize that in the UI by default :/ $\endgroup$ – 3Rton Dec 24 '18 at 12:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.