3
$\begingroup$

Pressing the "fit" button in the sidebar of the compositor doesn't stretch the backdrop to the edges of the viewport. It's scaled smaller than it's supposed to be. How do I make the auto-fit function properly fit the compositor backdrop?

$\endgroup$
3
+25
$\begingroup$

The Backdrop is merely a convenient display of what the Viewer node receives - to allow you to see the effect of changes to your compositor setup without having to switch away from the node view. The backdrop does not automatically resize as your viewport resizes - but does provide options to 'zoom' and offset the image - so you can position it so that the part of interest is not obscured by the nodes that you are working on.

Since the backdrop is intended as a convenient method of seeing a part of your render - so that you can tweak the nodes to see how it would look in the final render - it wouldn't make sense to distort those results (otherwise you wouldn't be seeing what would be output in your final render) - so there are no options to change the aspect ratio of the backdrop - so it cannot auto-fit to the shape of your viewport.

The 'Fit' button automatically sets the Zoom so as to position your render as large as possibly without any clipping - and this does mean that you will have blank 'bars' at the top and bottom, or at the side. Blender has no way of knowing which parts of the image you aren't currently interested in so you need to adjust the Zoom manually and optionally adjust the Offset to scale and position the image as desired.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.