I'm having trouble with my imported object. Its nowhere near the center of the grid where I need it to be.. I press the . key on my numpad and it takes me to it, but I am using a minecraft rig and need my object near the rig. This is probably basic to most of you but something I really need help with if you could! Thank you!!

The rig I am using shows up perfect in the center of my starting view where it needs to be


2 Answers 2


This method has always worked for me:

Firstly, is the origin of the Obj object at the center of the scene (0,0,0)?

If so, skip step 1 and go straight to step 2.

  1. Select the imported obj object whilst in object mode; press Shift+Ctrl+Alt+C. A menu will pop up with a few options - choose Origin to Geometry. (An orange dot should appear near the center of the object).
  2. Press Shift+C to reset the 3D cursor to 0,0,0 (this will change the view but as long as you don't deselect the imported object this won't be a problem).
  3. Press Shift+S and select the option Selection to Cursor - which will move the selected object to the center of the scene.

You will probably want to apply the location of the object after this. You may also need to get the origins to match, but that's for a different question and probably has already been answered somewhere.


For me blender always imports geometry to place where it was exported from. Eg. if I exported mesh that was in 10,0,0 then it would be imported to 10,0,0, not 0,0,0. What I would do, is first, check if origin/pivot/TheThingGeometryRotatesAround* of your mesh in c4d is centered on your object, not somewhere way off. Then I would double-check if its in 0,0,0 prior to exporting. After that I would export and import in blender, should work :)

*) Different software have different naming convention for something blender calls origin and 3ds max calls pivot, and probably different in other software.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .