-1
$\begingroup$

I followed Gleb Alexandrov's new glass tutorial (https://www.creativeshrimp.com/uber-glass-shader-blender.html), but I can't quite get it to work in a render. It seems to more or less work in the preview, as seen below. enter image description here

While it is rough, you can see through the glass, unlike what I get in actual renders. I should say early on that his tutorial is in 2.8 alpha, while I'm still using 2.79, but in the video he doesn't seem to say anything about this making a difference. enter image description here

I followed the tutorial to the dot and so far I've checked every node against his three times. What's weird to me is that the glass shader does seem to partially work on the sphere farthest to the left, but only within the solidify modifier. I've had issues like this once before with materials that work in the preview but not the render, and in both cases the material was transparent in some way. enter image description here

enter image description here

Those are my current render settings, the preview samples are high, but that is an instruction in the tutorial and it still works on lower settings.

$\endgroup$
  • 2
    $\begingroup$ Welcome to BSE. You should edit your answer to add more information to allow someone else to better understand your issue without having to track down and go through the tutorial you mention. Include a link to the tutorial as a bare minimum but also include things like images showing your nodes/materials and details of your render engine (cycles) and any other relevant details of how you have set up your scene. Ideally, someone should be able to read your question and follow your instructions to replicate the problem. $\endgroup$ – Rich Sedman Dec 21 '18 at 6:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.