0
$\begingroup$

When I try to do this with an object that I've made in solidworks the mesh looks absolutely terrible, spikes, jagged edges etc. You know the deal. I have tried doings "Tris to quads" and "Limited dissolve" with various values in order to fix this mesh. However neither of those methods has worked for me.

I have tried exporting the SolidWorks model in both .wrl format and .STL format, neither of which has looked good when I use the subdivision modifier, I have also looked for a way to export the model using quads instead of SolidWork's seemingly standard setting of exporting in Triangles.

Basically my question is:

How do I modify my export settings or change my mesh in such a way that subdivision surface is possible without ruining the mesh.

OR

If there is any way to make SolidWorks export in quads exclusively

$\endgroup$
  • 4
    $\begingroup$ I'm voting to close this question as off-topic because it is about Solid Works $\endgroup$ – Duarte Farrajota Ramos Dec 20 '18 at 17:09
  • 1
    $\begingroup$ If you want to use Subdivision you need carefully planned proper topology, no amount of export settings will fix CAD models $\endgroup$ – Duarte Farrajota Ramos Dec 20 '18 at 17:27
1
$\begingroup$

Having worked quite a bit with SolidWorks models myself, I understand your pain. There isn't a single quick fix, but there are some things I have learned that have helped me mitigate the poor topology.

The first thing you should do is merge triangle pairs into quads: In Edit Mode, press Alt + J.

enter image description here

Next, turn on Smooth Shading and Auto Smooth:

enter image description here

I have found these two will often smooth out the appearance enough that I don't need further subdivision.

In the case of the model I used as an example, though, I spent hours and hours reworking the topology in Edit mode to get it to the quality I wanted. As @Duarte said in the comments, the best thing is just to have good topology, which SolidWorks doesn't provide.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.