0
$\begingroup$

I seem to be having trouble with one of my UV meshes. For some reason, a number of vertices/faces have decided to detach themselves and, not only are there too many, but I can't re-attach them. The simplest thing to do is to unwrap the mesh again, but now I can't get it to align properly. The save I've attached is with the broken vertices... Any ideas what I could do? Thanks.

$\endgroup$
  • $\begingroup$ If you have multiple vertices sharing the same location, you can select all and press W -> Remove Doubles $\endgroup$ – Jan Kadeřábek Dec 19 '18 at 22:27
0
$\begingroup$

I don't think you can avoid re unwrapping.

The reason why you have the separate UV island in the head unwrap is because that is the way the UV seams are marked at the top of the head.

enter image description here

To make the head a single UV island clear the unwanted seams and mark a new one along the top of the head as in the screenshot below. Then UV unwrap again.

You will have to experiment a little to have the exact seams to get the correct unwrap island shape and then scale to match (align to) what you had before.

enter image description here

Just a note : usually the ears of a head will need UV seams so that they will be separate islands when unwrapped.

$\endgroup$
  • $\begingroup$ No, that's not the issue I'm having; that's intentional. When you load the save up, you'll see some of the faces/vertices of the UV map in the centre of the map. They've somehow become detached. However, if I unwrap again, I can't get the UV of the head/face to match up. No matter how much I resize it. $\endgroup$ – DustyShinigami Dec 20 '18 at 0:57
0
$\begingroup$

You're going to have to weld the vertices back in to place. There aren't that many, but if you're trying preserve your existing UVs, I don't think there's another way. I would turn on the Sync UV and Mesh Selection button and select a vertex. The vertex that it should be welded to will also highlight. Turn off the Sync button, move the vertex that is out of place over to the one that is in place and weld them together. That will work for the verts on the edges of the rips, and then it looks like you will have one or two loops in between the ripped edges that you will have to use your best guess at placing.

Edit: It looks like several vertices are mapped to a single point. You'll need to spread those out so you can see each vertex individually. You could possibly create new UVs for those to make your job a little easier. Turn on slection Sync, select the bad faces in the UV editor and unwrap in the 3d View. This will give you something cleaner to start with.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.