2
$\begingroup$

I have started learning blender and I have run into a problem when using solidify, bevel and subsurf together.

The problem is that the inner edges of the windows in my object have artifacts: inner edge artifacts zoomed out view

I want to create an object that is curved, so I am using the subsurf modifier. In the curved face I want to have a square window as shown. I am also using solidify to simplify modelling and bevel because no object has sharp edges. I am using the 'angle' option in the bevel modifier so that the bevels only go on the sharp edges.

I can fix the artifacts by adding more edge loops or applying the solidify modifier and setting edge weights, but I'd like to know if there's a way to fix it without doing that, because adding edge loops and applying solid makes my model more complicated and hard to edit the curved face (this is a simplified model to demonstrate the problem).

Blend file

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.