1
$\begingroup$

I am struggling with this problem for a while now.

I have created a procedural material for my buddy the low poly plant. I needs some tweaking but it's fine for now.

enter image description here

Now i want to join the separate leafs etc. in order to bake/export the plant.

This is where it goes wrong, the procedural material distorts when combining the object. (as in attached images)

enter image description here enter image description here

How can I prevent this? Is is possible to bake multiple objects to an combines mesh for example? I want to prevent to bake every part separately because I need to make variations and more high poly models afterwards.

$\endgroup$
0

1 Answer 1

1
$\begingroup$

You would need to make sure all the objects have UVs that do not overlap in the UV space. This way baking will work if all the objects share the same material and are selected.

In order to edit UVs for every leaf you would also need to make their data unique with Make Singe User. You can find it using the search in 2.8, or by going to Object>Relations>Make Single User.

It's also now possible to edit multiple objects at once in 2.8 so it's very easy to unwrap all the leafs to one UV map at once.

$\endgroup$
3
  • $\begingroup$ Thanks so much for your answer, this is setting me on track. However I do not know how I can avoid the UV's to overlap, because the the objects don't share the same UV map (I believe). Could you explain that or direct me to a link? $\endgroup$
    – Vince
    Dec 18, 2018 at 13:15
  • $\begingroup$ Oh thanks you edited your answer with the last paragraph I will try that. $\endgroup$
    – Vince
    Dec 18, 2018 at 13:16
  • 1
    $\begingroup$ You could re-unwrap the UVs by selecting all the objects, going to edit mode, selecting all with a and just unwrapping everything as if it was one object with u->u. You can then edit the UVs as you wish as you would do in 2.7 with one object except it will now affect all the selected objects. One really great new feature. $\endgroup$ Dec 18, 2018 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.