0
$\begingroup$

Please take a look at my node setup, viewer output, and then render.

I used the viewer node at two points so that I could make sure my color correction nodes were not the problem and even if I take the output straight from the keying node, the viewer shows the keyed scene over an alpha layer but then the rendered output puts the green screen and background all back in again.

I have been ripping the hair out of my head trying to figure out why this is happening. Several tutorials I've watched on Youtube show that if you take the output straight from a keying node into the compositing node and you composite using a format that has an alpha layer you are supposed to get just your keyed actor over a transparent alpha layer.

You can clearly see that on the top the viewer node has exactly what I want, but when I click render, the output on the bottom is completely wrong.

What am I doing wrong?

enter image description hereenter image description here

$\endgroup$
1
$\begingroup$

You'll have to re-think your keying process. Focus first on producing a proper matte from the greenscreen. In that stage, leave the RGB pixels alone and focus on the "matte" output of the keying node.

When you're done with that, connect another instance of the unmatted plate to a spill supressor and do all the colour correction and adjustments you need. Avoid doing a massive colour grading at this stage, the only color correction needed is to fix background spill and take the foreground color closer to the background, adjusting levels and neutralizing undesired casts. The creative part of colour correction doesn't have to be performed at this point, but after it's composited over the background.

Once you have a proper alpha channel and a corrected image, next step is setting the alpha channel to the corrected RGB. That's done with the "Set Alpha" node.

The result will be an "unassociated" (usually called "straight") alpha image.

In Blender's compositor you need it to be associated (often called "premultiplied), so you'll have to add an "Alpha Convert" node after the Set Alpha, from Key to Premultiplied.

The result will be an RGBA image ready to be composited over a background with a simple "alpha over" node (without marking the "Convert Premul" checkbox as it's already associated).

If you intend to composite it over the background using a different software and not Blender's compositor, then you just have to save the result to a format that supports alpha transparency (EXR would be ideal, but there are other formats).

There's an important thing to keep in mind: Blender's viewer is broken for associated alpha images, so don't trust how the viewer renders images with transparent background. Place a temporary solid background with an alpha over node and inspect the edges instead.

$\endgroup$
1
$\begingroup$

I figured out the problem and I feel really stupid now. Thank you for your help. I obviously still need to learn more about alpha channels and node editing. The solution was, that I had a copy of the original clip in the movie editor window and Blender was simply putting the movie clip I had in the background even though my node setup didn't have a parameter for that. The output ended up being the movie clip and not the keyed images.

Now I have to work on my blending and masking of her hand but I'm really happy to have solved this issue. Once again thanks all.enter image description here

$\endgroup$
  • $\begingroup$ Glad you solved it. I’d note that there is a wealth of useful information in @gez’s post here, and the others on alpha. It is worth spending time reading through them all, as it will unlock a huge amount of knowledge and elevate your work tremendously. Can’t recommend it enough. $\endgroup$ – troy_s Dec 19 '18 at 1:09
0
$\begingroup$

I'm not sure if I've messed something up. Most certainly I did. Ignore the chest core matte for the moment that with the nodes set up this way has way too much tapering. It still appears that I don't have a correct alpha channel. Not certain if I've connected the nodes quite as you've described. As you can see, in the viewer the background is transparent but in the render I still have all the keyed/masked out stuff. enter image description here

$\endgroup$
  • $\begingroup$ Don’t use the viewer or backdrop without an alpha over against a solid colour. What have you set the alpha to? ;) $\endgroup$ – troy_s Dec 18 '18 at 14:00
  • $\begingroup$ That alpha over node is not right. Replace it with a "set alpha" node. Corrected image to top socket, matte to bottom socket. The only line coming out from your keying node should be the matte. Don't use the "image" socket from that node. As I mentioned before, after your set alpha node, you'll have add a Alpha Convert node, turning your "key" alpha to "premultiplied" (associated). The result will be an image with transparent background, ready to be composited, this time with alpha over (just connecting background and foreground, and that's it) $\endgroup$ – Gez Dec 20 '18 at 17:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.