Recently, encountered a problem with this strange blue color in solid mode. It did not harm me until I exported this model, and this blue color combines with any material I add. For example, skin + blue = purple skin. It looks like a normal map, but I don’t know how to remove it from the mesh.

Any ideas? I'm new to Blender.

blue color in solid mode

  • $\begingroup$ You are using the Blender internal renderer, can you switch to Cycles? (drop down at the top of the Blender window) Internal is being depreciated and you will get more support using Cycles. $\endgroup$ – rob Dec 17 '18 at 15:21
  • $\begingroup$ Hi, can you provide the .blend file to take a look? $\endgroup$ – Francisco Arleo Dec 17 '18 at 15:32
  • $\begingroup$ Just in case you want to upload the file, use this link: blend-exchange.giantcowfilms.com $\endgroup$ – LeoNas Dec 17 '18 at 18:56
  • $\begingroup$ It's still possible to get expected behviour from Blender Internal even that it's to be dropped soon. There is mesh object with normal map texture shown on the screenshot, the fact that GLSL and Textured Solid are enabled means that the current texture is to be shown regardless currently selected texture in UV editor, see blender.stackexchange.com/a/5284/1245. The fact that this color combines with any other might probably mean texture slot with this blue texture is set to some Blend mode in texture settings other than Mix $\endgroup$ – Mr Zak Dec 17 '18 at 19:33
  • $\begingroup$ @FranciscoArleo I added blend file. $\endgroup$ – Pavel Serdziukou Dec 18 '18 at 9:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.