2
$\begingroup$

Whenever using ID-Masks (material and/or object) the result in the render output does not give me a solely black and white image. The whites are slightly darker than they should be. Even when overlaying an AO pass with a pure white color the result in the viewer/composite node is off-white.

Why is this?

Some additional info: enter image description here

Base render:

Base render

ID-Mask:

ID-Mask

Ambient Occlusion:

Ambient Occlusion

Blendfile:

$\endgroup$
  • $\begingroup$ Maybe it is a result of Filmic mode $\endgroup$ – Serge L Dec 17 '18 at 14:19
  • $\begingroup$ @SergeL I was thinking the same, but have no idea as to why this is happening. $\endgroup$ – Delagone Dec 18 '18 at 8:31
  • $\begingroup$ Main concept of Filmic is unlimited dynamic range, so it can have "whiter than white" color. But it is scene-refered color. To make it visible on display, default 1.0 value is greyed to make room for "whiter than white" color (like 10.0). With default color mode 1.0 and 10.0 value will look identical on your screen. $\endgroup$ – Serge L Dec 18 '18 at 8:51
  • $\begingroup$ @SergeL I understand...partially. Could you please elaborate your comment a bit more? Maybe post it as an answer and explain how to fix this? $\endgroup$ – Delagone Dec 27 '18 at 11:50
  • $\begingroup$ Actually I don't know how to fix it, except saving all maps in EXR except "beauty" pass. EXR doesn't store color management transformation and this is what you want for the File Output node (I assume you will import masks in external app?). Try "half float" option if you are short on free space. $\endgroup$ – Serge L Dec 27 '18 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.