0
$\begingroup$

I have my scene with building. Scene has HDRI light and some additional light sources (area light) inside building. Problems is - after turning on layer with light inside building all scene gets more noise.

Photo with light on (50 samples) http://www.part.lt/perziura/d74281caa2fff8977cdfece330bef225382.PNG Photo without light (20 samples) http://www.part.lt/perziura/74b2f9f35932cb707c639afe99faad22636.PNG

$\endgroup$
  • $\begingroup$ Try making the light source bigger. (Larger area) $\endgroup$ – Dr. Farquaad Dec 16 '18 at 16:31
1
$\begingroup$

Light is hard to calculate. Cycles is a path tracer, which means it shoots out light rays from the camera, bounces them around the scene and looks where they end up.

How many light rays are bounced is controlled by the "Samples" setting.

The issue that you're facing is that you've got a lot of light sources behind (I presume) glass panes, with a lot of geometry for the light to bounce around in. This is coupled with a very low sample count, and is the reasn for your noise.

Increasing the samples, leaving the lights turned off or decreasing light bounces might all be solutions to the issue you're facing at the moment.

If you find yourself sitting at 1000 samples or above with a lot of noise left then I'd recomment getting enabling the denoise in the scene settings. Be aware, this washes out colors and works against surface detail. Use it with caution!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.