6
$\begingroup$

Once I've baked a texture and want to save it - by default Blender offers me to save it as PNG RGBA, I change it to PNG RGB (no alpha) and save it.

The problem is that every time I re-bake the same texture and simply hit Save, it somehow saves as PNG RGBA again, not RGB as I saved it initially.

So I have two questions:

  1. Why is it not remembering my file format when saving with "Save", not with "Save as" (from uv window)?

  2. Where can I set its defaults to PNG RGB, so that every time I save a baked texture I won't have to go and click PNG RGB?

$\endgroup$
0
1
$\begingroup$

To change the default image file type produced by Blender, you actually want to change the image settings in the Render panel.

To change the default for a single file, go to the Properties>Render panel and scroll down to the 'Output' submenu. Then select the file format and BW/RGB/RGBA to your desired format.

enter image description here

If you want to set this as your default image type for all of your projects, first open a new file or open a new instance of Blender. Change the settings to what you would like to be default, then press Ctrl+U.

This changes your startup .blend file so that when you open future projects, they will come preloaded with these settings. It will not affect any of your old .blend files.

$\endgroup$
1
  • $\begingroup$ Well, thanks for the tip, however it seems not to cure the problem fully. After re-baking the texture it still saves as PNG RGBA, not PNG RGB. P.S. To clarify situation - i am not trying to render the scene, i am baking a texture. $\endgroup$
    – gans beija
    Jun 22 '13 at 7:58
0
$\begingroup$

It keeps defaulting to RGBA because the image has a alpha channel (and is trying not to loose information). Uncheck the Alpha option when creating the image and it'll default to RGB.

New image dialog

$\endgroup$
2
  • $\begingroup$ right, this one is unchecked for sure, no doubt about it. But right after the bake has happened, pressing F3 (Save As from UV window) gives me RGBA defaulted. And even then - if I specify RGB manually, then later on Alt+S (Save from UV window) saves it as RGBA again. So for some reason during the texture bake it thinks that it has Alpha channel in use. Under material textures - Image Sampling / Use Alpha is unchecked. Where else to look? $\endgroup$
    – gans beija
    Jun 22 '13 at 12:24
  • $\begingroup$ Additional/PNG saves do indeed always enable RGBA. This should be reported to the bug tracker. $\endgroup$
    – Aldrik
    Jun 22 '13 at 13:21
0
$\begingroup$

Thank you very much for bringing up this issue. I had the same problem where the saved render always display RGBA.

I managed to fix it by mainly going to my Node Editor > Properties Toolshelf (N) > Properties and unchecking Alpha.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.