1
$\begingroup$

How i can render glow from emission material over transparent background in blender 3D eevee, thanks! enter image description here

$\endgroup$
  • $\begingroup$ The glow you are showing was not made with emission material (Neihter Eevee nor Cycles add glow to emission) - was it bloom? I guess you need to use compositing for that. $\endgroup$ – internetofmine Dec 15 '18 at 19:41
  • $\begingroup$ I think it's either a bug either not supported yet. Maybe see with the devs on devtalk.blender.org $\endgroup$ – L0Lock Dec 15 '18 at 20:05
  • $\begingroup$ @internetofmine do you can helpme to build these compositing? $\endgroup$ – Yackson CC Dec 15 '18 at 21:57
2
$\begingroup$

Okay, I am not good with compositing but maybe will be able to help you a bit. It is a bit cheatish way to create a false bloom using gaussian blur. This should work with both cycles and eevee, my example is in eevee, which does not support lighting from emission material.

  1. First a basic scene with sphere, cube and transparent background:enter image description here

  2. What we want to do is to make the cube glow. We will do it like this:

    • Add a new view layer, so we have two view layers.
    • Sphere will be excluded from one view layer, cube will be excluded from another, each of them will have their own view layer.
  3. Lets add view layer: enter image description here

  4. Lets add collection and put cube into that collection enter image description here

  5. Set viewlayer to our first layer (defaultly named View Layer), select Collection 2 and exclude it from the layer: enter image description here

  6. Set view layer to the one we have added in step 3: enter image description here

  7. Select first collection (one with sphere, light and camera), right click it and exclude it from currently selected view layer: enter image description here

What we've done so far is set two view layers, have cube in collection 2 included in View Layer.001, and Camera, Sphere and Light included in View Layer.

  1. Now lets add emission material to our cube: enter image description here

  2. Open Compositing window, turn on Use Nodes, Auto Render and Backdrop. Two last options make preview of the render be rendered in the background whenever you change something in compositing nodes. As of this moment it seems to be requiring you to make one render before it starts working (just press f12 to render and then close rendered image). enter image description here

  3. What we are doing now is splitting image into two Render Layers, one for View Layer (with sphere) and other for View Layer.001 for Cube. Cube is blurred to create lighting aura effect and then added to cube (so we get a solid cube with blurred cube behind it). Then we add sphere from view Layer on top of that. Connecting to Composite node causes it to be renders output, Viewer node is required for Backdrop to display. enter image description here

  4. And final render: enter image description here

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ thanks for your help, it is amazing :D i now can continue doing my prerendered game, thanks thanks! $\endgroup$ – Yackson CC Dec 20 '18 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.