1
$\begingroup$

I created a simple render with a compositing node: the "fog glow". I want to make one object give off this glow. However, not only can I not find a way to affect only that object, it doesn't even show up in the rendered result.enter image description here

These are the nodes I've used. Am I missing something?

I am using Cycles Render, not Blender Render!

Here's the render (I was fiddling around with it after a few responses and have come up with nothing, clearly.)

$\endgroup$
0
$\begingroup$

There are two problems here. The first is that you are not getting any fog glow and this is easy to resolve - the problem is that only parts of the image that are above the Threshold setting of the Fog Glow node will be made to glow. As you appear to not have any bright emission parts of your render, using a Threshold of 1.0 will result in no glow - try reducing the Threshold in order to see the glow.

As for the separating the glow so as to only affect certain objects in the scene, you can use the Object Index render pass to generate a mask in order to affect only those elements that you require to 'glow'. In order to do this, first give each of your objects that you require to glow a specific Object Index by setting the Pass Index in the Object properties in the right-hand panel :

Pass Index

Enable the Object Index pass by enabling it in the Render Layer :

Render Layer Object Index pass

In the Compositor Nodes, you can now use the following nodes :

Compositor Nodes

Here the ID Mask is set to the same Index as you have used to identify your object(s). This will produce 1.0 for each pixel corresponding to the parts you want to 'glow' and 0.0 for the rest of the image. The subsequent Mix nodes generate two images - one where the objects matching the Index are black while the rest of the image is shown, while the other where the object is shown with the rest of the image black.

The Fog Glow can then be applied to the relevant image to apply the glow - ensure to set the Threshold to zero so as to glow everything that is greater than 'black'.

All that is now required is to recombine the two images using the Add mode - any black regions will be replaced with the other image. Since the masks used to generate the images are mutually exclusive, only the 'glow' parts of the images will overlap.

This can produce the following result :

result


Looking at your Blend file, you've got some minor differences in your setup that are affecting your results. This should be amended as follows :

amendments

Not the highlighted changes; the Mix nodes should be mixing black (otherwise the white will also be "glared"), the two branches should be combined with Add instead of Mix, the Fog Glow needs a lower Threshold.

Note that the Fog Glow produces quite a subtle effect. A quick way to increase it would be to chain multiple Fog Glow nodes together :

amended result

$\endgroup$
  • $\begingroup$ I noticed that this was in Blender render. I'm using Cycles. Should they work the same? I followed all your instructions exactly, and can see no other difference between the two. $\endgroup$ – Claire Dec 21 '18 at 11:32
  • $\begingroup$ @Claire I was also using Cycles - I’ll download your Blend file later and take a closer look. $\endgroup$ – Rich Sedman Dec 21 '18 at 11:50
  • $\begingroup$ Okay, clearly I'm clueless, then. I'm fairly new to Blender, if you hadn't noticed already. Thank you. $\endgroup$ – Claire Dec 21 '18 at 12:14
  • $\begingroup$ @Claire No wories - it only takes one thing to be wrong and the whole result is ruined - it can be very confusing! I've spotted a couple of problems with your nodes which are causing it to not work. I've added an edit - hopefully this helps. $\endgroup$ – Rich Sedman Dec 21 '18 at 13:55
  • 1
    $\begingroup$ It has worked! Thank you so much for your help! I will be using this in the future. $\endgroup$ – Claire Dec 22 '18 at 1:17
0
$\begingroup$

One way is to create two render layers and then mix them in the compositor. For instance

Nodes

Here is how I made my example

  1. Create the entire scene on layer 1 as usual. For the example I placed a sphere in front of a cube.scene
  2. Move the object that you want the glow on to another layer. For the example I moved the cube to layer 2.
  3. In properties -> Scene modify the 'Scene' layers to contain both layers and 'Layer' layers to contain only layer 1 RenderLayer
  4. Add a new Render Layer. Being lazy I left its name as "RenderLayer.001". Adjust its 'Layer' layers to contain only layer 2 and disable 'Use Environment'RenderLayer.001
$\endgroup$
  • $\begingroup$ I tried this, followed every step, but the object I was trying to make glow simply disappeared. It's shadow and glow were there, but the actual object was nowhere to be found. $\endgroup$ – Claire Dec 16 '18 at 21:40
  • $\begingroup$ can you add your blend file to your question? Grab the URL of the question Go to blend-exchange.giantcowfilms.com Select the blend file Add the url of the question Grab the url that results Go back to the question and edit it Add the new url to the bottom of the post $\endgroup$ – Marty Fouts Dec 17 '18 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.