0
$\begingroup$

I made a model and I'm trying to add color to it, but for some reason the colored texture doesn't show on the model. I can't see any difference in the model. These are the steps I followed:

  1. I unwrapped the model.
  2. I made a blank image of the model and I baked it with 'bake mode: ambient occlusion'.
  3. I created two .PNG files: one of the already made 'ambient occlusion' and another one of UV layout to work with them in Photoshop.
  4. I copied the 'ambient occlusion' image to the 'UV' image as a second layer and I just added some color to see if it shows color in the preview of the model in Blender, but it doesn't.

This is my model (the viewport is in 'texture' mode):

enter image description here

Maybe I have not followed the right steps, or I've overlooked something. I'd appreciate any idea of how to solve it. Thanks!

$\endgroup$
1
$\begingroup$

To add an image texture to your model you need to follow these steps (There might be other ways, by the way; but this is the way that i would do it):

  1. UV Unwrap your model
  2. Add a new material to it

    enter image description here

    enter image description here

  3. Add your image texture to the material

    enter image description here

    enter image description here

    And you should be good to go

    enter image description here

$\endgroup$
  • $\begingroup$ It's not a good idea to teach on Blender Renderer nowadays, it's obsolete and will be removed from further Blender versions. $\endgroup$ – L0Lock Dec 13 '18 at 13:21
  • $\begingroup$ Yeah i know, but i didn't mention cycles since he was referring to the internal renderer in his question and i didn't want to get "off-topic?" $\endgroup$ – Isho Antar Dec 13 '18 at 13:43
  • $\begingroup$ AFAIK he is just starting Blender, he might be unaware of those things. And since he's asking for such a basic thing, I think it's important on our side to go ahead and lead him in a nice way for the long run. $\endgroup$ – L0Lock Dec 13 '18 at 14:02
  • 1
    $\begingroup$ Yeah thats a good point, you got a +1 from me; $\endgroup$ – Isho Antar Dec 13 '18 at 14:08
1
$\begingroup$

Textures are only color information, they aren't linked in any way to your mesh.
Materials, on the other hand, are the things defining how your models appear and how light affects them. And you use your textures as inputs in your materials.

What you need to do now, is creating your materials.

Since you're in Blender Renderer and it's an old renderer about to be removed from Blender, I suggest you switch to a more recent renderer, Blender Cycles: enter image description here

Then in your object's material tab, create a new material. It will automatically create a very simple default material, composed of a single "diffuse node" which only handles color basically. It's enough for now. In the color input, you can choose a color, or hit the little side dot to add a node in there. Select the Image Texture node, then hit "open" to find your texture in your folder. Or if you have already loaded your texture in blender, you can use the little drop-down menu on the left.
enter image description here
This should be enough.

I suggest you to do further studies on Cycles. How to use its materials system, how to do lighting and render with it, ... This list of videos might be a good start.

$\endgroup$
0
$\begingroup$

Or you can select the texture in edit mode. Go to edit mode and in UV/image editor select your texture and it shoul be visible in textured view. This will however only show you the texture on the model. There won't be any textured material.

$\endgroup$
0
$\begingroup$

If you are using the Blender Internal Engine try setting the viewport to "Materials".

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.