1
$\begingroup$

I installed most recent blender from ppa:thomas-schiex/blender to get the most recent blender version. Starting blender now results in crash. Running blender inside terminal from directory /usr/lib/blender leaves me with

Fatal Python error: Py_Initialize: Unable to get the locale encoding
ModuleNotFoundError: No module named 'encodings'

So far I found out that I need to install python sources. To find them I installed Synaptic Package manager and searched for them and couldnt find them. Therefor I also ran

apt-get source python

I still get that error when I start blender from Terminal. Perhaps anyone knows how to resolve that?

$\endgroup$
0
$\begingroup$

Others seemed to have a similar issue as well but couldnt resolve it: Blender with system python failing

Here is my solution also posted over there:

All right... I had the same error appearing today and I have been able to solve it. It's been pretty easy. After removing blender and installing blender from ppa:thomas-schiex/blender There were some files still around. To make sure everything works try:

sudo apt-get purge blender
cd /usr/lib
sudo rm -r blender
sudo add-apt-repository ppa:thomas-schiex/blender
sudo apt-get update
sudo apt-get install blender

Since everything is purged AND manually removed from versions installed manually it should be fine now. Have fun :)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.