3
$\begingroup$

enter image description here

I'm not sure what cause this. I checked everything but it didn't work so I had to load default set which solved the problem. (I assure you that I wasn't edit mode) I still wonder what was the problem..

$\endgroup$
  • 2
    $\begingroup$ Are you aware of the default keymap changes? It's Left click select now, and the whole left click keymap is different from the RCS one. $\endgroup$ – L0Lock Dec 11 '18 at 8:34
  • $\begingroup$ Hey Thanks for the reply. Yes I'm aware of that. I solved problem by deleting user preference. $\endgroup$ – blender baby Dec 11 '18 at 15:38
  • $\begingroup$ Related blender.stackexchange.com/questions/95354/… $\endgroup$ – Duarte Farrajota Ramos Sep 29 '19 at 18:34
  • $\begingroup$ I noticed that when I'm in object mode and accidentally hit the 1 key (in vertex mode: edit mode). That it hides the collection i'm currently in. Somehow hiding the collection doesn't hide the object but does disable selecting it. I removed the hotkey in the settings file and now my object remains selectable. $\endgroup$ – Pieter De Bie Dec 14 '19 at 6:36
2
$\begingroup$

No I think there is something seriously wrong with the outliner window. Prior to 2.8 selecting something in the outliner positively selected it in the 3d viewport. The outliner in 2.8 is erratic. Selecting something in the outliner does not necessarily select it in the 3d.

$\endgroup$
  • 2
    $\begingroup$ do you mean the outliner? $\endgroup$ – user1853 Feb 22 '19 at 20:10
  • $\begingroup$ I doubt that. The Outliner works pretty much as expected with many objects and in many scenes I have tested. Also, this should be a comment. Also also, if you think you found a bug, please help the developers to fix it by posting it on the official bug tracker $\endgroup$ – metaphor_set Apr 2 '19 at 14:32
1
$\begingroup$

I just found the solution. Box select is default in 2.8. Press T to bring up tools and hold down on box select to change it to normal selection.

Hope that helps!

$\endgroup$
1
$\begingroup$

It looks like you set up "Disable selection for viewport selection" for one of your Collection with objects you couldn't select. You can check it in the outliner.

$\endgroup$
-1
$\begingroup$

I have had the same problem; and, I've been able to fix it by selecting Load Factory Settings under File. Nothing I've done seems to be affected, but the left selection does work again after Load Factory Settings.

$\endgroup$
  • 1
    $\begingroup$ The person solved the problem and you just repeated it without adding anything. Waste of time. $\endgroup$ – Lukasz-40sth Jun 28 '19 at 19:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.