1
$\begingroup$

I've attached an example for Blender 2.8. I tried the same scene on Blender 2.79b and everything worked as it should.
This is how it works in ViewPort:
This is what I get by rendering (any render engine):

Seems like a constraint does not work.
Here are the Camera constraints:

Here is the Empty constraint:

The Empty is a parent of the Cube.
And the blend file.
Is it a bug? Should I report it?

$\endgroup$
3
$\begingroup$

No, it's not a bug.

This is actually known issue called "dependency cycle"

If you open blender with terminal, you will see like this:

Dependency cycle detected:
  'OBCamera.TRANSFORM_CONSTRAINTS()' depends on 'OBEmpty.TRANSFORM_FINAL()' through 'Damped Track'
  'OBEmpty.TRANSFORM_FINAL()' depends on 'OBEmpty.TRANSFORM_CONSTRAINTS()' through 'ObConstraints -> Done'

This means that one constraint depends on second, second on first one. So current camera rotation cannot be calculated correctly, because there is no start point to start with.

To solve this, fix dependency in your scene

I've tried "blender --enable-new-depsgraph" with blender 2.79b and it still works despite the new kind of the error messages

You will get same errors in 2.79:

Dependency cycle detected:
  Empty depends on Camera through Copy Location.
  Camera depends on Empty through Damped Track.

And the fact that 2.79 in this error situation doing something different, does not mean that 2.80 has a bug or something. Look at glitch with camera movement when I change frame:

enter image description here

The only way to solve this problem - do not build cycles in dependencies. Add an empty for follow path, second empty will follows this one, and camera will depends on first and second empties:

enter image description here Camera moved a little for clarity

No dependency cycles - no problems.

$\endgroup$
  • $\begingroup$ But why does it work in ViewPort and on Blender 2.79b? $\endgroup$ – theemmah Dec 10 '18 at 18:00
  • $\begingroup$ I've tried "blender --enable-new-depsgraph" with blender 2.79b and it still works despite the new kind of the error messages. $\endgroup$ – theemmah Dec 10 '18 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.