1
$\begingroup$

I have made a very basic animation in Blender (2.79) and I am trying to export it as a GLTF or GLB. I have succesfully installed the gltf exporter and am able to export both gltfs and glbs of unanimated models no problem.

As soon as I add animation and try to export however, I get the following error message

enter image description here

The animation is as about as simple as it could be, I'm just experimenting. Its just the default box that changes location and rotation across 3/4 keyframes.

enter image description here

I am new to Blender so perhaps I am missing a step but my process is as follows: Add box to the scene, add keyframes (LocRot), go to export as I would with a static object, this has the following (default) settings.

enter image description here

I have tried clicking Pushdown on the action sheet as I have seen suggested somewhere but it makes no difference.

Am I missing something? Please let me know if you need any more info in order to advise, I'm happy to share the file or whatever might help.

Thanks for any help,

$\endgroup$
0
$\begingroup$

The GLTF format is to blame as "the animation support in glTF is insufficient for accurately reproducing animations created in most popular modeling software (including Blender, Autodesk 3ds Max, and Autodesk Maya) due to the requirement that time be linear for cubic spline interpolation." as Eric Lengyel says And, just in case, uncheck "keyframes start with 0" as in Blender the default start frame is 1.

$\endgroup$
  • $\begingroup$ Hi, thank you for the suggestion but the keyframes start check did not make a difference. It was the force sample animations one that I was missing (see my answer). $\endgroup$ – Nick Dec 7 '18 at 22:35
0
$\begingroup$

So after seeing someone else's export settings (thanks to the a-frame slack channel) I have got this working. I needed to have force sample animations selected in the animation export settings. Then it exports no problem and works as expected. Answering my own question in case anyone else has this problem.

Thanks.

$\endgroup$
0
$\begingroup$

Here's how I got it to work:

1) Upgrade to the latest Blender 2.8.1

2) Go to export panel:

Export -> glTF -> Presets

3) Set the options:

Transform -> +Y Up
Animations -> Always sample animations

4) Test your exported animation in a viewer:

https://gltf-viewer.donmccurdy.com/

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.