-1
$\begingroup$

I got Auto-Rig Pro recently, I kinda need help figuring it out.

After I skin my bones to my mesh with their custom handles and go into pose mode, I move the armature and not the mesh.
They are bound correctly, just for some reason they are not moving.

If anyone has the time and has Auto-Rig Pro, I have the file on my google drive labeled "help plz".

https://drive.google.com/drive/folders/1Ap6QjKtmTHhvTeKNM5Gdu8N0qKy87Rmv?usp=sharing

$\endgroup$
  • $\begingroup$ You really should clearly warn when you're sharing mature content. Be responsible, kids are on the internet. Also, please provide your full work. In this case, the model and the rig you made. We're supposed to see what you did, not guess it with black magic. $\endgroup$ – L0Lock Dec 6 '18 at 8:59
  • $\begingroup$ yeah sorry about that, i deleted the rig because if you are using the auto rig then load someone elses blend file with yours, it gets a bit messy from my experience, if you try rigging it, you will see what I mean $\endgroup$ – gengas Dec 7 '18 at 7:39
0
$\begingroup$

I think it's mostly that your vertex groups names don't correspond to your rig's bones. A bone can deform only the mesh assigned to a group with its name.

|improve this answer|||||
$\endgroup$
0
$\begingroup$

You've probably worked this out by now, but in case anyone else finds this in here, the documentation helped a lot:

http://www.lucky3d.fr/auto-rig-pro/doc/faq.html#binding-does-not-work-or-partially-work-help

I went through this one-by-one, and in the end the problem was cause by only two vertices in the same place! After doing a 'merge by distance' (Alt+M) it removed two vertices and suddenly it worked.

It seems a little crazy that it's so sensitive, but I guess there's some reason, and the answer was in the documents. Let's give a shout out to whoever writes and updates documentation - it's probably a very thankless task and we all rely on them. Cheers document person!

|improve this answer|||||
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.