0
$\begingroup$

I've generated a .dae file with a skeleton, but the bones seem to be misplaced when importing into Blender.

It looks like if "find bone chains" and "auto connect" are off, then only leaf bones are positioned correctly; all others are at position (0,0,0), and some are missing entirely, not even present in the outliner. If those options are on, the bones look like they're placed correctly but not rotated correctly.

What's really suspicious is that when those options are on, the bones are placed incorrectly at first, but by selecting the armature and pressing R to rotate, they immediately snap to "correct" positions (even without actually rotating). So something strange is happening there.

DAE file: http://ix.io/1vlh

When first imported: Bone positions when first imported

After pressing R: Bone positions after pressing R

Fix Leaf Bones is on in both cases; turning it off makes no difference except that all the bones point straight up. Blender version 2.79b on Arch Linux x64.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.