0
$\begingroup$

I've created a model in Blender that I want to texture in Substance Painter.

As you can see in the picture, I've marked those edges as sharp and auto-smoothed the model, and then I beveled them in the high poly version of the same model in order to bake a normal map in SP. Problem is that I get some artifacts when baking normals.

enter image description here

After searching in order to solve the issue, I've found that it's a good thing to mark as seams the sharp edges on the model, but I still get the same result, maybe slightly better.

I'm not sure what I'm doing wrong. Should I remove the sharp edges from the HP model?

EDIT:

This is what it looks like without sharp edges or autosmooth on

enter image description here

with autosmooth / sharp edges

enter image description here

what happens in Unity if I don't auto-smooth the model

enter image description here

$\endgroup$
0
$\begingroup$

At what resolution you are baking your maps usually if you dont have visible artifacts on the normal map, and everything seems to be even, without any artifacting it may be your resolution if you are texturing at lower resolution like 1k for a small object, try to use 2k up to 4k for a standard game model, maybe if its not a game model but for a commercial or animation try 8k or 16k as its going to be close to the camera.

Also, if you are using the creasing option of blender DONT! unless you want a really sharp edge, dont use it or you can create artifacts, i. If you want a crease that is not as sharp in your lowpoly add a subsurface modifier and add loops were you want the crease. You may need to redo the UVS though, maybe.

And one last thing, if you have the lowpoly and the highpoly models coming from blender make sure their origin points, the 3 axis manipulator is exactly the same. A slight change of positioning in one mesh or the other can cause severe artifacting. if they are not position right, just put the mesh that is out of place were the other mesh is preferibly if you can both meshes at The world's origin point and export it again.

I hope it helps I had those kind of issues everytime, the struggle to bake perfect and beutiful normal maps...sigh.

Goodluck.

$\endgroup$
  • $\begingroup$ i'm using the sharp edge option, and that's probably what is causing the issue.. point is that, if I don't use the auto-smooth or the sharp edge option, the smoothing shade is way different..and as you can see, it affects the way the model looks in unity as well..I'll post a picture in the OP for that. if I use the subdivision surface modifier on my low poly, it goes way too high with the polygons and this must be used in a videogame. $\endgroup$ – Raio Boss Dec 6 '18 at 13:47
  • $\begingroup$ Ok is this going to be a background object, and what type of game you are making like a shooter or something like 3rd person view, and the 3d model is going to be close to the camera? $\endgroup$ – Eduardo Alfaro Hernandez Dec 6 '18 at 18:07
  • $\begingroup$ in the end I've just worked a lil bit more on the geometry and added some, and it seems to be working.. in the end I could use some more polygons with no issues and went for it.Thanks $\endgroup$ – Raio Boss Dec 6 '18 at 23:44
  • $\begingroup$ Good that you figure it out. :) Goodluck $\endgroup$ – Eduardo Alfaro Hernandez Dec 7 '18 at 0:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.