4
$\begingroup$

I noticed a flickering background whenever I click a button or orbit in blender 2.8 or 2.79

It only happens when I use my NVIDIA 940mx but not when I switch to the integrated Intel 620.

I can't record the effect with a screen recorder, so it might be related to the NVIDIA driver interacting with the display brightness/gamma/contrast.

Maybe someone has experienced this problem and knows how to fix it? Also, is there any disadvantage of using the integrated graphics? Especially on 2.8 and eevee?

$\endgroup$
4
  • 1
    $\begingroup$ try File > User Preferences > System, and under the Window Draw Method select Triple Buffer. $\endgroup$
    – rob
    Dec 3 '18 at 12:12
  • $\begingroup$ thx, window draw method was not the solution. it's independent from this setting. just appearing with nvidia gfx enabled. intel is working fine. $\endgroup$
    – Simon Sais
    Dec 3 '18 at 14:56
  • $\begingroup$ In the OpenGL settings of the Nvidia controls, try disabling Sync to Vblank $\endgroup$
    – user1853
    Mar 13 '19 at 15:53
  • $\begingroup$ I have the same problem with my GTX1050 (MSI PS63 laptop.) I've tried toggle Window Fullscreen and it was help me. It's working. Does anyone to know another solution? How we can fix it without full screen mode. $\endgroup$
    – Antony
    Sep 1 '19 at 18:27
7
$\begingroup$

After about a year with the same issue, I found a solution: use Blender in REAL fullscreen mode. By that, I mean, do not use it with maximized window, go to Window > Toggle Window Fullscreen. This solved the problem both in Blender 2.79b and in 2.80.

I dunno if we have the same machine, I'm using an Acer Aspire-E5, but it uses the same graphics card, 940MX.

I feel like this is some sort of conflict between it and the integrated graphics card, where when idle, it uses the Intel card. This would explain this bug, and another one I was getting recently in 2.79b, were the interface would not show what was really happenning currently and show still images of stuff that happenned.

`Putting the software in fullscreen may tell the NVIDIA card that it can take full control of it, so those bugs don't happen.

$\endgroup$
1
  • $\begingroup$ Thanks, this worked on NVIDIA Xavier Dev Kit!. $\endgroup$
    – Martin
    Apr 7 at 7:18
2
$\begingroup$

This happens sometimes when your clipping distances in the camera settings are to short. When I set the clipping distance at 0 everything starts to flicker. Hope that helps.

$\endgroup$
1
$\begingroup$

I was having the same problem, screen flickering when I would orbit/move in the viewport and when navigating the menus.

For me the fix was to turn AMD Free sync on the monitor off, it seemed to be causing issues with the hertz settings of my monitor i.e., windows was set to 144hz but with Free sync on the monitor was set to 50hz.

$\endgroup$
1
  • $\begingroup$ Disabling freesync on the monitor did it for me, I have no internal graphics and only 1 gpu (gtx 1080) $\endgroup$
    – DevShot
    Sep 7 at 11:47
1
$\begingroup$

In the Nvidia (advanced) settings there is an option to turn off 'Automatic gaussian correction'. That did it! No more flicker! Hope this might be yet another cure option for somebody out there...

$\endgroup$
0
$\begingroup$

Your conclusion is spot on. The notebook is alternating between the 2 video cards, causing this strange issue.

Let me suggest something that may be useful to you: go to control panel > device manager and I disable the weak video card and re-enable it back again. The computer immediately stops lagging (until the next reboot).

It worked for me with Blender, there's no flickering, even when windowed. Hope it works for you too.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.