0
$\begingroup$

I'm trying to 3D print a statue of a character that has a thin skirt. Problem comes in when I export and load it into a slicer, both Cura and S3D, it doesn't recognize sections of the skirt and won't print said sections. I'm trying all the print thin wall tricks I know, and even with a 0.25 nozzle on my Ultimaker 2, I'm still not getting anywhere. I also attempted to scale up in the slicer and rotate so the model would print on it's back, or tilted at 45 degrees.

Cura 3.5

On the Blender side of things, I've searched up and down trying to figure this out, and so far, nothing worked. I tried Solidify, Displace, Subsurf. I tried separating the skirt to conduct its own modifiers, and reattaching. I tried scaling the model as the first thing I do in Blender, but that caused major distortion when I copy over the pose data. I've played around with each modifier options at each step. Still can't really figure anything out.

Skirt

Since the model seems alright in Blender, I go and export model as OBJ, and run it through MS 3D Builder to correct anything. I tried Netfabb for correction, but the model is too much for Netfabb to handle. I'm out of ideas, and I've asked on a FB group, and all I got was everything I found on my own and tried already. I really don't know where to go from here, and tbh, I don't even know if its a Blender problem or not, but any help is appreciated. Willing to share model if need be.

Thank you!

UPDATE: Added model for anyone kindly enough to help- https://drive.google.com/open?id=1XijAr2Aowmr-zLuCmdM8pEiTsomrhuQK

$\endgroup$
  • 1
    $\begingroup$ Unless you've already done it... I'd recommend a 1st step?.. in Object Mode, Shift-Ctrl-Alt M to select non-manifold features of your model.. See what shows up.Then you might wind up with a specific problem to solve. I would suspect the skirt is a single-layer region attached to an already manifold body. It would need to be separated, thickened and reattached in such a way as the body and the skirt form a watertight, non self-intersecting whole. $\endgroup$ – Robin Betts Dec 2 '18 at 10:46
  • $\begingroup$ @RobinBetts But that an advanced thing to do in blender. I think to remodel it completly from scratch with the manifold criteria is simpler than correcting that triangle-mesh model $\endgroup$ – HenrikD Dec 2 '18 at 14:30
  • $\begingroup$ By the way. Press W and Remove Doubles and then Ctrl+N to recalculate Normals, to get rid of most of those artifacts $\endgroup$ – HenrikD Dec 2 '18 at 14:31
  • $\begingroup$ @HenrikD .. you could be right, Depends how healthy the mesh is.. I suppose XX could post the Blend so we could have a look... :) $\endgroup$ – Robin Betts Dec 2 '18 at 14:48
  • $\begingroup$ I put a link to a fresh start of the file on the OP, only thing I did was copy the pose over. Touched nothing else. I tried the Select Non-Manifold features, and I got a lot, mostly with the skirt section. I tried Remesh for correction, but that nuked the model. I had a bit of luck with following @HenrikD's advice, and I got more of the skirt recognized by Cura, but still not printable. $\endgroup$ – Xx_Lady_Green_Heart_xX Dec 2 '18 at 18:53
0
$\begingroup$

What you are asking for is professional help to make the model printable. The problem with your model is that your 3D Printer (No matter which kind you have) is not able to print that thin clothing. Actually thats not even the real problem. The real problem is that Slic3r or Cura can not know what shape that is because is has no inside. It is just flat. Thats why it doesn't appears when sliced. I dont know if you had a look at some other dressed character figurines, but they have usually quite thick clothing. For example habe a look at models of ballerinas on thingiverse. Thats why you tried Solidify right? But wait there is more! Not only has your object to be manifold (closed) it also needs to be one non-intersecting object to be sliced correctly. Usually when the Remesh Modifier works fine on your mesh its printable. It didn't for you right? Thats because you had intersecting geometry. As I am here writing, I am not writing this to make you go: "Oh thats impossible to do for me", so I have a quick solution for you which might actually work. If it isn't perfect enough, just make it perfekt in sculpt mode. So here is what you need to do:

  1. Make a Proxymesh of your Character in his/her posed position. What that means is: Make a mesh that surrounds your character and is really simple when it comes to the polygons. Around 200 or 300 Faces will work well I think. You should use the Mirror Modifier to make the symmetry perfect if you can (I dont know your Pose)
  2. Add a Subdivision Surface Modifier, a Shrinkwrap Modifier and a Remesh Modifier
  3. Tweak the Settings. Most Important is the Shrinkwrap Modifier. You have to set the mode to either Nearest Surface Point or to Project. In Case you set it to Project, which I think will work much better on your model, you have to make sure negative and maybe positive is checked and none of the X,Y,Z checkboxes are checked. The Modifier will then move the vertices of your mesh along their Normals until they hit the Surface of your model (obviously you have to specify which model in the box Target)
  4. Apply everything, go into Sculpt Mode (use symmetry if you can) and fix everything thats not quite there
  5. Print it!
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.