0
$\begingroup$

Currently I'm creating a very low-poly model where there needs to be a high contrast between different Surfaces, so the normals of each surface must be equal to the perpendicular of the surface.

When I try to smart UV unwrap my model, without changing the model, no UV's are connected. If I want to create a nice unwrap with proper UV islands, I remove all vertex doubles and afterwards smart unwrap the model.

The problem with this method, is that now the normals are automatically smoothed, which destroys the preferred look of the model.

Is there a way to properly smart UV unwrap a model without removing the vertex doubles? Or might there be a way to get normals perpendicular to the surface after removing the doubles?

$\endgroup$
1
$\begingroup$

Select the edges you want to be sharp, press Ctrl + E, mark sharp. Add modifier: Edge Split. Check Edge Angle to do it automatically. Check Sharp Edges to do it manually. Check both for a combination.

You can later also select all edges you marked sharp (use the space search function, I don't know what menu it's under), then mark them as seams if you want. Seams tell blender where to separate geometry. Usually, this is where sharp edges are, in order to hide seams on textures.

| improve this answer | |
$\endgroup$
  • $\begingroup$ The Option is called "Auto-Smooth" and has a Degree Input, its in the Object Data Panel in the "Normals" Section. For "mark sharp" to actually work, this option needs to be enabled. $\endgroup$ – Chris Feb 21 '19 at 22:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.