2
$\begingroup$

How can I enable adaptive subdivision in Blender 2.8? I have a noise texture plugged into the displacement output for a material, with the displacement method set to Displacement Only. There is no "adaptive" option for my subdivision surface modifier, however, when I increase the subdivision levels manually, the mesh is displaced in the rendered view.

I am rendering with cycles with the 2.8 beta version downloaded today.

$\endgroup$
  • $\begingroup$ Make sure you're in experimental mode! $\endgroup$ – Dr. Farquaad Nov 30 '18 at 1:32
  • $\begingroup$ How do I enable that in 2.8? $\endgroup$ – Erik Nov 30 '18 at 1:51
6
$\begingroup$

Here are the steps:

  • Select Cycles for Render Engine
  • Select Experimental for Feature Set
  • Select Dicing Rate and Preview count in Subdivision drop down
  • Select Subdivision Modifier from Modifiers tab but do not apply it
  • Check Adaptive check box and choose dicing scale
  • Done!

I hope that helps

Demo Video

$\endgroup$
  • $\begingroup$ Do NOT apply the modifier. $\endgroup$ – L0Lock Nov 30 '18 at 12:17
  • 1
    $\begingroup$ @L0Lock thanks. Forgot about that. Corrected the same. $\endgroup$ – Neeraj Lagwankar Nov 30 '18 at 13:22
  • $\begingroup$ How do I enable experimental mode in Blender 2.8? $\endgroup$ – Erik Dec 1 '18 at 1:28
  • $\begingroup$ The button is no longer in the same place it was in 2.79 $\endgroup$ – Erik Dec 1 '18 at 2:01
  • $\begingroup$ Modified the answer. I'm also commenting because I'm not sure whether you get a notification whenever an answer is edited or not. $\endgroup$ – Neeraj Lagwankar Dec 2 '18 at 2:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.