0
$\begingroup$

The problem from my previous question is partly fixed, it still has a strange shading to it

enter image description here

enter image description here

$\endgroup$
7
  • 3
    $\begingroup$ As I mentioned in the other question, it'd be WAY easier for someone to help you if you posted your .blend file. If you're concerned about someone stealing your model, just cut out the badly shaded part and upload that piece. $\endgroup$ Nov 27, 2018 at 5:46
  • $\begingroup$ Is this shading problem visible in the final rendering? $\endgroup$
    – Secrop
    Nov 27, 2018 at 5:50
  • 1
    $\begingroup$ it looks like you have smoothed your object (T panel > Tools > Shading > Smooth) but, as it has not enough faces, it creates this sort of shades. If so (?) you can artificially increase the topology with a Subdivision Surface modifier (Subdivisions of 2), but you may need to create additional edges to sharp some angles. $\endgroup$
    – moonboots
    Nov 27, 2018 at 8:50
  • $\begingroup$ Adding geometry to fix the shading is not the best option. Use the shading tools first. $\endgroup$
    – L0Lock
    Nov 27, 2018 at 13:22
  • 1
    $\begingroup$ @MichaelMacha The guy asking this question over three years ago hasn't been very active since then, I doubt your comment will be read by him anyway. $\endgroup$ Feb 23, 2022 at 14:45

1 Answer 1

1
$\begingroup$

Now it's exactly the inverse problem from before. You used to have to prevent edges from being sharp, now you need to mark some sharp edges so they don't appear smooth.

You can do this the same way before, selection the edges supposed to be sharp, CtrlE → Mark sharp. The issue with this method is that you need to do this everywhere needed; It's quite long to do.

Fortunately, you can let the software do most of the work for you; Since the idea is to mark sharp when some faces do a certain angle, you can go to the Data tab of your object, and find the Auto Smooth option in the Normals tab :

enter image description here

The way it works is simple. Once enable it smoothes the whole mesh, but mark as sharp every edge forming at least the angle specified below. I use 66 usually, it's a nice value; You can adapt this to your need.

(Also, all the sharp marked edges only work with auto smooth enabled).

$\endgroup$
2
  • $\begingroup$ it doesn't work it becomes segmented again when I tried this $\endgroup$ Nov 29, 2018 at 22:19
  • $\begingroup$ what do you mean "segmented"? Images are worth thousands of words. $\endgroup$
    – L0Lock
    Nov 30, 2018 at 8:37

Not the answer you're looking for? Browse other questions tagged .