1
$\begingroup$

Blender 2.79 (sub0) was installed on a fresh system (Ubuntu 18.04) through apt. I found the shortcut keys are not functioning in the 3D View window:

  • No response to A (selection) X(deletion) or any other shortcuts.

  • Not able to edit the shortcut in the user preferences.

Below is the debug info when I press A with --debug-all enabled:

Switching to fully guarded memory allocator.
read file /home/sywe1/.config/blender/2.79/config/userpref.blend
  Version 279 sub 0 date unknown hash unknown
Read prefs: /home/sywe1/.config/blender/2.79/config/userpref.blend
read file 
  Version 272 sub 2 date unknown hash unknown

ordered
 OBCube
 OBLamp
 OBCamera
ED_screen_refresh: set screen
SRNA Subclassed: 'Context'
SRNA Subclassed: 'Operator'
SRNA Subclassed: 'PropertyGroup'
SRNA Subclassed: 'Menu'
time bl_operators 0.0405
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Bone'
SRNA Subclassed: 'EditBone'
SRNA Subclassed: 'PoseBone'
SRNA Subclassed: 'UIList'
SRNA Subclassed: 'Mesh'
SRNA Subclassed: 'Object'
SRNA Subclassed: 'Texture'
SRNA Subclassed: 'Header'
time bl_ui 0.1236
SRNA Subclassed: 'KeyingSetInfo'
time keyingsets_builtins 0.0022
SRNA Subclassed: 'Node'
SRNA Subclassed: 'NodeInternal'
SRNA Subclassed: 'ShaderNode'
SRNA Subclassed: 'CompositorNode'
SRNA Subclassed: 'TextureNode'
time nodeitems_builtins 0.0058
SRNA Subclassed: 'WindowManager'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Operator'
    addon_utils.enable io_scene_3ds
SRNA Subclassed: 'Operator'
    addon_utils.enable io_scene_fbx
SRNA Subclassed: 'Operator'
    addon_utils.enable io_anim_bvh
SRNA Subclassed: 'Operator'
    addon_utils.enable io_mesh_ply
SRNA Subclassed: 'Operator'
    addon_utils.enable io_scene_obj
SRNA Subclassed: 'Operator'
    addon_utils.enable io_scene_x3d
SRNA Subclassed: 'Operator'
    addon_utils.enable io_mesh_stl
SRNA Subclassed: 'Operator'
    addon_utils.enable io_mesh_uv_layout
SRNA Subclassed: 'Operator'
    addon_utils.enable io_curve_svg
SRNA Subclassed: 'RenderEngine'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Operator'
SRNA Subclassed: 'PropertyGroup'
SRNA Subclassed: 'AddonPreferences'
I1125 14:49:07.065317 12441 blender_python.cpp:186] Debug flags initialized to:
CPU flags:
  AVX2   : True
  AVX    : True
  SSE4.1 : True
  SSE3   : True
  SSE2   : True
  QBVH   : True
  Split  : False
CUDA flags:
 Adaptive Compile: False
OpenCL flags:
  Device type    : ALL
  Kernel type    : DEFAULT
  Debug          : False
  Single program : True
  Memory limit   : 0
    addon_utils.enable cycles
SRNA Subclassed: 'Operator'
    addon_utils.enable import_off
Python Script Load Time 0.2067
FRS_set_context: context 0x0x7fd2834c80b8 scene 0x0x7fd27b204038
bpy.ops.wm.splash()
WM_operator_last_properties_store: storing properties for 'WM_OT_splash'
ghost_event_proc: window 1 state = normal
ghost_event_proc: ghost redraw 1
Thread 0: update object OBCube
recalcob Cube
Thread 11: update object OBCamera
recalcob Camera
recalcdata Cube
Thread 4: update object OBLamp
recalcob Lamp
Thread 0: total 1 objects in 0.000032 sec.
  Cube in 0.000032 sec
Thread 1: total 0 objects in 0.000000 sec.
Thread 2: total 0 objects in 0.000000 sec.
Thread 3: total 0 objects in 0.000000 sec.
Thread 4: total 1 objects in 0.000032 sec.
  Lamp in 0.000032 sec
Thread 5: total 0 objects in 0.000000 sec.
Thread 6: total 0 objects in 0.000000 sec.
Thread 7: total 0 objects in 0.000000 sec.
Thread 8: total 0 objects in 0.000000 sec.
Thread 9: total 0 objects in 0.000000 sec.
Thread 10: total 0 objects in 0.000000 sec.
Thread 11: total 1 objects in 0.000010 sec.
  Camera in 0.000010 sec
Scene updated 3 objects in 0.000082 sec
ED_screen_refresh: set screen

wm_event_do_handlers: Handling event
wmEvent  type:272 / TIMER, val:0 / NOTHING,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(5810,976), ascii:'', utf8:'', keymap_idname:(null), pointer:0x7fd2644dc0b8

wm_event_do_handlers: Handling event
wmEvent  type:272 / TIMER, val:0 / NOTHING,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(5810,976), ascii:'', utf8:'', keymap_idname:(null), pointer:0x7fd264aa1738

wm_event_do_handlers: Handling event
wmEvent  type:260 / WINDOW_DEACTIVATE, val:0 / NOTHING,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(1383,920), ascii:'', utf8:'', keymap_idname:(null), pointer:0x7fd2644db578
ghost_event_proc: window 1 state = normal
ED_screen_refresh: set screen

wm_event_do_handlers: Handling event
wmEvent  type:97 / A, val:2 / RELEASE,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(1348,418), ascii:'', utf8:'', keymap_idname:(null), pointer:0x7fd264e8a7f8

wm_event_do_handlers: Handling event
wmEvent  type:97 / A, val:2 / RELEASE,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(1348,418), ascii:'', utf8:'', keymap_idname:(null), pointer:0x7fd264e8a7f8

wm_event_do_handlers: Handling event
wmEvent  type:1 / LEFTMOUSE, val:1 / PRESS,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(1335,407), ascii:'', utf8:'', keymap_idname:(null), pointer:0x7fd264f84638

wm_event_do_handlers: Handling event
wmEvent  type:1 / LEFTMOUSE, val:2 / RELEASE,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(1335,407), ascii:'', utf8:'', keymap_idname:(null), pointer:0x7fd264e896b8

wm_event_do_handlers: Handling event
wmEvent  type:171 / UNKNOWN, val:1 / PRESS,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(1339,407), ascii:'', utf8:'a', keymap_idname:(null), pointer:0x7fd264e89538

wm_event_do_handlers: Handling event
wmEvent  type:97 / A, val:2 / RELEASE,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(1339,407), ascii:'', utf8:'', keymap_idname:(null), pointer:0x7fd264e89538

wm_event_do_handlers: Handling event
wmEvent  type:97 / A, val:2 / RELEASE,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(1339,407), ascii:'', utf8:'', keymap_idname:(null), pointer:0x7fd264e89538

It seems that blender received the keypress event but does nothing to it. Does any know how to fix it? Thanks in advance.

Solved

Set the input source back to en_us solved my problem.

$\endgroup$
3
  • $\begingroup$ I've not used linux for a while, but if my memories are correct and not outdated nor biased, apt doesn't have the latest blender version (something like 2.6) unless you add your own ppa. Are you sure you have 2.79? Anyway, do you have this issue after rebooting Blender? Have you tried re-installing? $\endgroup$ – L0Lock Nov 25 '18 at 22:48
  • $\begingroup$ @L0Lock Yes, I'm sure the apt version is 2.79 as well. Also, I tried to download a new tar packed blender, but it runs into the same issue. I guess it may be incompatible with ubuntu 18.04 since blender 2.79 works well on my 16.04 computer. $\endgroup$ – PolarStar Nov 25 '18 at 23:01
  • 2
    $\begingroup$ I see you've edited your topic to include a solution. Maybe post it as an answer as well? $\endgroup$ – L0Lock Nov 26 '18 at 8:09
1
$\begingroup$

Set the input source back to en_us solved my problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.