0
$\begingroup$

I have a simple character (below) that is in the middle of an animation that does not work with my logic bricks.

Character in middle of animation

Here are my logic bricks. Sorry, may be hard to read (click on the image for a bigger version).

Logic Bricks

It states that when the property inMovement is set to 1, it will play a walk animation, and, on the other hand, it will not when it is set to 0. I thought that the problem would be with the parenting, but it all looked fine:

Outliner

After this I thought that the animation just didn't work, but it did. This is the animation of my blocky character picture at top.

Animations.

Everything I stated here is true, and I did not lie and/or take pictures at different times. All the screenshots were taken at one point in time, and no editing was done between them.

How do I get the animations to play (Loop Stop) based on whether the value is set to 1 or 0?

$\endgroup$
  • $\begingroup$ Could you post a .blend file? $\endgroup$ – GiantCowFilms Jun 19 '14 at 1:00
1
$\begingroup$

I'm currently making a game myself, and what i do is connect the W A S D keyboard sensors to individual AND controllers. These each go to seperate MOTION actuators directing the speed and direction to walk in (A and D can be set to rotation). Then create an ACTION actuator with your animation in it and connect it up to the AND controllers of the W A S D sensors. You can reverse the animation for S key by duplicating the ACTION actuator and reversing the KEYFRAMES. If A and D are for rotating, don't add the action.

$\endgroup$
  • $\begingroup$ Thanks! That is an answer, but I already had it solved. $\endgroup$ – blackhole Jul 22 '14 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.