3
$\begingroup$

When I open blender, the command box pops up, goes away, a grey window opens and then closes immediately with no error message or anything. Even when running as administrator. From following some other posts on the issue I did manage to get an "exception_access_violation" error when running in cmd.

I've completely reinstalled blender multiple times now (always going in and manually deleting anything left behind after each install in AppData and program files) I've tried both of my hard drives, both 64 and 32 bit, both zipped and installer. I've tried reinstalling my graphics driver and running the intel processor updater (though it said there was nothing to update)

I've tried downloading a new opengl32.dll but putting it in the blender install directory did nothing, and when I try to replace the system32 one it says I need permission even after granting administrator permission.

I very recently completely wiped my entire computer and installed a fresh version of windows 10. and Blender was running fine for a while. The only thing I can think of that I for sure did between it working and not working is that I updated my graphics card driver (Nvidia GeForce GTX 1070. Now ver 416.94)

Anyone else having this problem? Any suggestions on fixes? I'm banging my head against a wall here.

$\endgroup$
1
$\begingroup$

Ok, so the best way to solve mysterious bugs like this is to divide and conquer. Basically try to isolate things that might cause it and run experiments that rule those things out. What you end up with at the end will be the issue.

We can't really be of much help since this process requires access to the machine with the issue. But perhaps trying this method may help you.

So, you've mentioned you have an access violation? That, sadly for you, is the equivalent of announcing you've lost your needle in a particular haystack.

Something you could perhaps try is to run blender from the command line with some of its debugging options. For instance try

blender.exe --debug

There's no guarantee that you won't get a crash, but at this stage, its probably beneficial to try and gather more information that will narrow down where the problem is.

$\endgroup$
  • $\begingroup$ Sometimes the error happens because Windows sometimes decides that blender violates some policy for accessing the graphics system. Usually there's a popup that allows you to white list blender. Unfortunately, I don't recall how to white list when the popup doesn't appear. $\endgroup$ – Marty Fouts Nov 23 '18 at 22:25
  • $\begingroup$ So I'm not sure if I'm just doing it wrong (I don't use the command console often) but to open it I've been using the line cmd /K "C:\Program Files\Blender Foundation\Blender\blender.exe" When I try to add the --debug to it I just get "C:\Program is not recognized... error message. Running my command again I did notice some other messages I didn't see before though: AL lib: (EE) UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead found bundled pythin: "2.79\python directory" Then the EXCEPTION_ACCESS_VIOLATION error $\endgroup$ – Austin Alander Nov 23 '18 at 22:58
  • $\begingroup$ Hi @AustinAlander, can you post the output of your console here? Please include the command you are using. Happy to take a look :) $\endgroup$ – James Crowther Nov 23 '18 at 23:04
  • $\begingroup$ Managed to get the debug command working I think. Got this: C:\Users\lilti>blender -d Switching to fully guarded memory allocator. Blender 2.79 (sub 0) Build: Thu 03/22/2018 09:59 AM Windows argv[0] = blender argv[1] = -d read file Version 272 sub 2 date unknown hash unknown ordered OBCube OBLamp OBCamera found bundled python: C:\Program Files\Blender Foundation\Blender\2.79\python Error: EXCEPTION_ACCESS_VIOLATION $\endgroup$ – Austin Alander Nov 23 '18 at 23:14
  • $\begingroup$ Yeah, there's not a great deal of helpful information there, perhaps try enabling all debug messages, you can do this by changing from -d to debug-all, sorry I am on a mac OS system so the command might be different for you on windows. You should be able to get a list of all command line options by doing something like blender.exe --help $\endgroup$ – James Crowther Nov 24 '18 at 3:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.