2
$\begingroup$

Most of us know Eevee's Ambient Occlusion

My issue is I have models such has hair with its own custom normals and the AO in Eevee is causing it to look weird.

No AO

With AO

Is there a way to remove the AO effect from specific objects? I thought it could be done using the AO node but im unsure.

$\endgroup$
1
  • 1
    $\begingroup$ wow, the ambient occlusion looks so much better. anyway, have you tried using eevee's emission attribute? $\endgroup$
    – SilverRain
    Commented Nov 22, 2018 at 4:56

2 Answers 2

3
$\begingroup$

Real time renders don't use real Ambient Occlusion, they uses SSAO - Screen Space Ambient Occlusion which is a depth based effect applied to the whole view.

As far as I know it can't be filtered or masked.

As a workaround render separate layers and combine them in post production.

$\endgroup$
2
$\begingroup$

enter image description here

  • Look into your shader properties.
  • Under "Settings tab".
  • Check the "Screen Space Refraction" checkbox.

Any material with SS Refraction turned on will not render screen space AO under Eevee, but materials doesn't have it enabled will still able to generate AO on to it. Note that this doesn't work on Cycles, as they treat materials differently.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .