0
$\begingroup$

Isn't blender supposed to handle scene units internally? One would think if they modelled a 1m x 1m cube, it should stay that way across blender files. Any insight regarding this would be great. Does this mean cycles thinks I'm rendering a kilometer-wide room?

Even with 2.8, where the units were supposedly fixed, I still encounter the same problem. Though, with 2.8 the scene units no longer changes to 0.001 when selecting millimeters.

In preparation for 2.8, is there a way I could batch convert my old models' scale instead of having to manually scale each object for every blender file?

Thank you in advance.

$\endgroup$
  • $\begingroup$ Common problem when importing from various formats but it stays the same so when U know U have to make it for example 10-times smaller its the same everytime so I think its not a big deal (encounter the same problem with 3DS Max). $\endgroup$ – Jan Matys Nov 21 '18 at 20:54
  • $\begingroup$ By 'import' do you mean link or append from another blender file or do you mean using one of the import file functions? When you set the units in a blend file before creating the cube, and in the new file before linking/appending, it should work. Select just the Units preset without setting the Length units appropriately definitely confuses 2.79 $\endgroup$ – Marty Fouts Nov 21 '18 at 22:59
  • 1
    $\begingroup$ Note this is from one blend file to the other, no format conversion. Same thing happens regardless of append, link or copy to buffer. If I set scene units in 2.79, it works because it changes the scale scene units as well. But in 2.8 it doesn't til I explicitly change the scale as well. $\endgroup$ – Rey Leonard Amorato Nov 22 '18 at 3:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.