0
$\begingroup$

EDIT: So now I have my answer, 2.8 doesn't work with my OS (10.9.5), but it works with a more recent one like Mojave.

I wonder how to enable Eevee on a Macbook pro. For the moment if I choose Eevee as Render Engine, here is the result I get (image below, Rendered mode with no material). I also screenshot my Preferences if it helps. My Macbook Pro is a Retina, 15 pouces, mid-2014, the video card is Intel Iris Pro (GPU type), OS X (version 10.9.5).

Thanks a lot!!!

enter image description here

$\endgroup$
  • $\begingroup$ It would be helpful if you could add the specs of your MBP. There should be some kind of Compute Device showing up. It could be possible that your GPU is not supported. Have you added any kind of materials to your objects yet? - Also, are you in rendered view? $\endgroup$ – michaelh Nov 21 '18 at 9:58
  • $\begingroup$ Hello Michaelh, thanks for your answer, the screenshot is in Rendered mode, the objects have no material, the MBP is a Retina, 15 pouces, mid-2014, the video card is Intel Iris Pro (GPU type), I hope it helps $\endgroup$ – moonboots Nov 21 '18 at 10:43
  • $\begingroup$ I just installed the latest build of 2.8 on my MBP mit 2012 and Eevee works just fine. ("fine" meaning very slowly, but it works). It is odd, that you have only "none" for Cycles Compute Device. There should be more Tabs and AT LEAST your CPU should show up. Are you on Mojave? It looks like something on your System is just not supported, yet. You could check other applications if they show your hardware, just to be sure it's Blender related and not sth. else. Also, always try the latest builds. Amazing Blender Devs keep fixing stuff all the time. $\endgroup$ – michaelh Nov 21 '18 at 11:16
  • $\begingroup$ my OS is 10.9.5, and same problem with the latest version of Blender 2.8. If I switch to Cycles I can choose between Device > CPU or GPU Compute (but I still have a None on the System Preferences). If you have any idea please tell me, I'm also going to ask on devtalk.blender.org, thanks ;) $\endgroup$ – moonboots Nov 21 '18 at 11:30
  • 1
    $\begingroup$ I've tried Mojave and it works. My problem is that for the moment it will be a bit complicated to switch to Mojave, but I least I know where the problem comes from. Thanks to you! $\endgroup$ – moonboots Nov 27 '18 at 21:36
1
$\begingroup$

It's not something you have to enable, EEVEE is just here and you have to chose it as your current render engine, just like before.

Go in the properties editor, you'll find a drop-down menu for choosing your render engine at the very top of the render tab :

renderer drop down

EDIT: As the OP is already in rendered view in EEVEE and without materials, then it looks like a bug.

$\endgroup$
  • $\begingroup$ Hello Lolock, actually I've already chosen Eevee, the screenshot I show is the result I've got ;) $\endgroup$ – moonboots Nov 21 '18 at 9:43
  • $\begingroup$ Then you have nothing else to do \o/ $\endgroup$ – L0Lock Nov 21 '18 at 9:48
  • $\begingroup$ I don't know what you mean $\endgroup$ – moonboots Nov 21 '18 at 9:52
  • $\begingroup$ Me neither, what are you trying to do? Once you've switched your render engine to be EEVEE, that's it, nothing else needed to use EEVEE. $\endgroup$ – L0Lock Nov 21 '18 at 9:54
  • $\begingroup$ looks what I've got when I switch to Eevee (screenshot). Don't you think there's a problem? $\endgroup$ – moonboots Nov 21 '18 at 10:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.