I'm using 2.8 Is there no default short key combo to remove duplicates now?

I see that I can quickly add a shortcut for it - but it seems to me that it's something that should be in the mesh (w) menu. I use it all the time.


  • 2
    $\begingroup$ Try checking in the vertex menu 😀 $\endgroup$
    – Linguini
    Nov 21, 2018 at 5:18
  • 1
    $\begingroup$ Yeah, just did. Gosh, I'm sorry. $\endgroup$
    – 220
    Nov 21, 2018 at 5:21
  • $\begingroup$ You're good! happy blendering and have fun with 2.8 $\endgroup$
    – Linguini
    Nov 21, 2018 at 17:21

3 Answers 3


As of writing this answer, the option is not present in Blender, or at least not searchable through F3 and buried somewhere deep. What works instead, is merging by distance by either of these methods:

(remember to first select at least two vertices: at least one will be kept, while those, that are too close to kept vertices (depending on the setting), will be removed)

  1. From the Mesh menu select Clean up and then Merge by distance.
  2. [No longer in 2.90.1] From the Vertex menu select Merge Vertices and then by distance.
  3. From the context menu (right mouse button by default) select Merge Vertices and then by distance.
  4. Press M, then B keys. [before 2.90.1 Alt+M, then B keys.]

A panel with settings will appear on bottom left:

Blender 2.8 collapsed Merge by Distance panel

After clicking it, it will expand:

expanded merge by distance dialog box

On bottom you should see the number of removed vertices, depending on current setting:

status message indicating number of removed vertices

Step-by-step example

  1. Press CTRL+N, then G for a new general file.
  2. Make sure the cube is selected.
  3. Press TAB to enter edit mode
  4. Press ALT+A to deselect all vertices.
  5. Click on a vertex.
  6. Press G twice, and slide the vertex as far to another vertex as possible, so they both occupy the same position, confirm by clicking.
  7. Press A to select all vertices (to make sure both vertices in the same spot are selected)
  8. Press M, then B to merge by distance. Regardless of the setting, at least one vertex will be removed which should be confirmed by a status bar message: status message indicating number of removed vertices
  9. Press ALT+A to deselect all vertices again.
  10. Click on the vertex that had a "duplicate" on the same position.
  11. Either press G to start moving the vertex and see all edges are connected to just this one, and the other is gone or H to hide the vertex and see there's no second vertex at the same spot.

animated screen capture of the step-by-step example

Beware, that this will remove not only vertices that have the exact same coordinates, but also those that are within 0.0001m of each-other. You can decrease this value to as low as 0.000001m.

Thanks to the comments from Hikariztw and JtheNinja, I investigated the issue and indeed the old remove doubles worked exactly the same. In Blender 2.79 the merge distance seemed to default to zero:

Blender 2.79 remove doubles settings

but after clicking the input field it would reveal that the 0.000 was just a rounded view of an actual non-zero value:

old merge distance input after clicking on it

In both cases (Blender 2.79 and Blender 2.8) the default value is 0.0001m and the minimum value is 0.000001m (in Blender 2.79 you have to go to scene settings and set metric system for length in order to see 1 micrometer instead of 0.000001 without a unit).

  • 4
    $\begingroup$ The Beware part is the original behavior that remove double/merge in distance operator do. The name changing is mainly to inform people how this is work in practices. $\endgroup$
    – HikariTW
    May 4, 2019 at 13:53
  • 4
    $\begingroup$ To further clarify, this IS the remove doubles tool. It's the same tool under the hood, just with a new name and UI location. $\endgroup$
    – JtheNinja
    May 12, 2019 at 23:49
  • $\begingroup$ Could you update your answer to reflect the behavior in 2.91? I am unable to perform this once simple operation (mesh > clean up > merge by distance does not delete vertices that I know are overlapping) $\endgroup$ Nov 26, 2020 at 7:08
  • $\begingroup$ @MicroMachine I checked in 2.91 and everything works as expected, so I decided to add a clarification, that vertices have to be selected and a step-by-step example how to use this feature. If you still have problems, consider asking a new question with your specific problem. $\endgroup$ Nov 27, 2020 at 11:44
  • $\begingroup$ Thanks @MarkusvonBroady . I was extruding a text and then converting to mesh and the front, back and edges of each letters was disconnected. If the issue happens again I will make a Q. $\endgroup$ Nov 27, 2020 at 17:03

Blender 2.8 is in development. It's an unfinished alpha product constantly changing hour after hour. So if you're not prepared to constantly change with it, consider waiting for the 2.80 release.

For now, the default keymap is one of the things currently being worked on. You can follow the advancement on the tracker here. There is also a list of shortcut being made here.

If you can't find a function used to be called via an obsolete shortcut, you can try to search it via the search menu (now bound to F3), or watch in the different menus in the viewport's header:
viewport's header

BTW, it seems to be in the "Context menu" (W, previously called "Specials menu") in today's build. But you have to be in vertex selection, as it's an operation on vertices and the new context menu is meant to show different tools according to the context:
enter image description here


In edit mode, select Mesh>Clean Up>Remove Doubles

  • 3
    $\begingroup$ Add an image to illustrate this. $\endgroup$ Feb 26, 2019 at 9:06
  • 1
    $\begingroup$ Where in the view does it say how many vertices were removed? Can't find it. $\endgroup$
    – cigar_matt
    Apr 22, 2019 at 22:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .