2
$\begingroup$

I have this problem:

enter image description here

As you can see Viewer shows 0.0 while it should show frame 118 or 119.. Frame node does not update while scrubbing in timeline. Anyone had this problem as well?

I've checked "Frame changed" and/or "Always" in Auto execution tab. But it does no effect anything.. Maybe I missed something else

$\endgroup$
  • $\begingroup$ If you have auto execution enabled it should work. I tested it, it works for me. Can you give us some more info and/or provide your blend-file? I'll have a look later. $\endgroup$ – bstnhnsl Nov 20 '18 at 10:29
  • $\begingroup$ Thats the problem.. In a new scene everything worked.. in this one it does not.. I did not get to create this scene from the start, so I don't know if anything was pressed there or not.. that is why I asked if there is any other place to turn on/off things like refresh and stuff. $\endgroup$ – Julius Ra Nov 20 '18 at 11:21
  • $\begingroup$ Did you check the documentation on execution? $\endgroup$ – Omar Emara Nov 20 '18 at 11:33
  • $\begingroup$ Ok.. I found something Interesting.. The scene had a couple of Sub scenes created in it. cdn.discordapp.com/attachments/194901346183413761/… And the Time info node works in the "Directory" (I guess First) scene. Bud does not work in "Hero" and in "Portal" scenes.. $\endgroup$ – Julius Ra Nov 20 '18 at 11:59
  • $\begingroup$ Ok.. I think I've was able to duplicate the problem. I'v created new scene. And added a couple of more subscene to it.. and the problem repeated it self. In the primary scene Node tree worked.. in the subsequent ones - did not.. Now The question is.. How do I link Animation Nodes with the exact Scene? $\endgroup$ – Julius Ra Nov 20 '18 at 12:13
1
$\begingroup$

Again, I've asked and I will answer..

scene select

Just choose to which scene the Animation Node Tree will belong to. Sorry if this was in documentation and I did not understand it correctly.. I believe this should be explained in more details. Because everything else worked.. except the Frame update, that's why I got confused and searched in wrong place at first.

$\endgroup$
  • $\begingroup$ We have not explained that in the documentation at all, and we intend to fix it. Thanks for bringing this up. Please accept your own answer if it answers your questions. $\endgroup$ – Omar Emara Nov 27 '18 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.