0
$\begingroup$

I'm looking at shortcuts in version 2.79b, specifically:

  • shiftnumpad-enter
  • which calls view3d.zoom_camera_1_to_1
  • and is supposed to "Match the camera to 1:1 to the render output"

When in camera view, and "Lock camera to view" option is on, I can zoom or dolly the camera with shiftMMB or shiftctrlMMB. Pressing shiftnumpad-enter doesn't do anything though (laptop with azerty layout and external numeric keypad).

  1. I read: Is it possible to view the scene in the viewport camera view at 1:1? but the question is dated 2014 and the explanations seem not relevant in current version.

  2. From the comments and answer so far, changing the number of pixels in the render settings should allow for the effect to be seen. But it's not the case:

    enter image description here

My questions are (for version 2.79b):

  • How do we use shiftnumpad-enter?
  • Why it doesn't work on my configuration?
$\endgroup$
  • $\begingroup$ Look through the camera (Numpad5), press Shift NumpadEnter. It works for me as described. $\endgroup$ – Leander Nov 20 '18 at 9:52
  • $\begingroup$ @Leander. I assume you mean (numpad-0). It works for you "as described"... described where? So that I can understand what is the intention. To me it does nothing apparent (azerty keyboard, and external numeric keypad, in case that has some influence). $\endgroup$ – mins Nov 20 '18 at 9:56
  • $\begingroup$ Shift NumpadEnter works exactly as described in the linked question. The answer is still valid and not obsolete/deprecated. $\endgroup$ – Leander Nov 20 '18 at 10:46
  • $\begingroup$ @Leander: That's not working on my side, question updated with a screencast. Now it seems (thanks Martin Z) this could be a keyboard problem. The screencast tends to go in that direction (key identified as Enter, not Numpad-Enter). Targus usb keyboard $\endgroup$ – mins Nov 20 '18 at 12:04
  • $\begingroup$ If the answer is different I think you should answer your own question with details, so that it remains for others who might have the same issue to see. $\endgroup$ – Martynas Žiemys Nov 20 '18 at 12:29
1
$\begingroup$

I initially didn't understand what was the purpose of the shorcut, as nothing was happening. After some exchanges on the site, Martin Z suggested to check whether the menu option (View | Navigation | Zoom Camera 1:1) did show the same problem. It didn't, the menu option worked as expected.

Confirm the problem is with the shortcut

This is an indication of a potential keyboard problem, and for those suspecting something similar:

  • Confirm the shortcut is really the one you think. You may look at the menu entry or use space to display the search window. The shortcut will be indicated near the description of the function.

  • If the shortcut is the one expected, then try running the function using the menu. If it doesn't work better, then the problem is elsewhere.

Keyboard problem confirmed... what is the cause?

In my case I use a laptop and an external USB keypad. The problem is the keypad, which brand is Targus:

enter image description here

I don't know whether this device doesn't generate the correct key code for key Enter, or whether Blender developers didn't bother or weren't able to differentiate the internal keyboard Enter from the USB keypad Enter, but in Blender API both keys appear the same.

Workaround

The solution is to change the shortcut associated with the function. It's done in user preferences (open this window with the combination ctrlaltU (or menu entry File | User Preferences in the "Info" header).

Select Input tab and type a part of the function name, for instance "1:1" in my case, in the search field to display the function and its binding:

enter image description here

  • Put the mouse pointer over the keyboard shortcut
  • Press Enter to activate the key recorder
  • Type a new shortcut, in my case crtlaltreturn to prevent overwriting one already in use.

Don't forget to save the user preferences, else the new binding will be lost when Blender will be closed.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.