2
$\begingroup$

I searched for all the questions around here and i still couldnt find how to fix this. Im going mad already. I've done tutorials and everything i could, unwrapped, set materials, create image, and still i cant paint on my mesh. it doesnt matter what i do, i cant paint on it. i really need some help to how to be able to paint the models, because im trying to make a game and im stuck here, cant move on on anything until i finish this :\

enter image description here

enter image description here

EDIT: more screens enter image description here

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ could you share your file? blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Nov 18 '18 at 17:33
  • $\begingroup$ Wops, wanted to say, there it is. $\endgroup$ – Rodrigo Nov 18 '18 at 18:17
  • $\begingroup$ Reduce to a simple set up in a new file - append just the single mesh object, clear the materials and start with a simple generated new image in the UV Image Editor set to Color Grid or UV Grid. IN the Node editor, set up a new cycles material with the image node referencing the new generated image from the UV Image Editor. In Edit mode, make sure the UVs appear on top of the image in the UV Editor. In Texture Paint, see if the image now shows up and allows you to paint. If that is too complex, try setting up a basic cube for paint and look at the difference in set up. $\endgroup$ – Craig D Jones Nov 19 '18 at 15:45
1
$\begingroup$

Edit: so it looks like your problem was the Face Selection Masking option (on the horizontal menu bar, the icon with a red and whithe chessboard), it allows to paint only the selected faces.

Old answer:

First you need to create an Image Texture in the material so that you can paint on something: In the Node Editor, enable Use Nodes and make a chain with your Image Texture node > Diffuse > Output.

I can't see your "PlayerSkin" image, maybe it's because it was not packed with the file. So you can use this image, if it exists, or another one, as the Image Texture.

Also, your unwrap is very special, you probably made a simple Unwrap but it doesn't respect the proportions of the topology. To directly paint on your object you can simply use the Smart UV Project option when unwrapping.

| improve this answer | |
$\endgroup$
  • $\begingroup$ like this? (updated main post with more screens) i selected the material, went to textures, selected image, created a new one 2048x2048, but i still can't paint on it. im not sure how to pack the image with the blend file? i mean, it's just a blank image cause i never got able to paint it. I used the Smart UV project, and clicked the nodes, but still nothing. $\endgroup$ – Rodrigo Nov 18 '18 at 20:43
  • $\begingroup$ well it works fine on my computer: create a new image, create the node chain, load the image you've created in the Image Texture node, select your mesh and unwrap > Smart UV Project, switch to Texture Paint mode, choose your color and paint. If it still doesn't work for you, perhaps pack your image and share again... $\endgroup$ – moonboots Nov 18 '18 at 20:54
  • $\begingroup$ maybe you need to disable the Face Selection Masking option? (on the horizontal menu bar, the icon with a red and whithe chessboard), it allows to paint only the selected faces $\endgroup$ – moonboots Nov 18 '18 at 21:24
  • $\begingroup$ Oh man, the face selection masking was the thing messing with me mostly i see now. I managed to paint, however, what i did was just adding a texture but not material, like you said, but i dont know if it will work for a game? I really thank you for taking the time to answer and helping me!! $\endgroup$ – Rodrigo Nov 19 '18 at 20:46
  • $\begingroup$ ok great! I don't know about how it works for games, though ;) $\endgroup$ – moonboots Nov 19 '18 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.