I'm trying to rig an object's wheel in a way that when I translate a bone of it in positive Z LOCAL axis, that wheel object to rotate accordingly on the positive X LOCAL axis.

The problem is that when I translate the bone in local, the wheel is rotating in WORLD Space and NOT LOCAL as I set it up.

Transformation Modifier

So the modifiers look like this:

  • Extrapolate checked
  • Source: Location - Z: min. 0, max. 2
  • Source to Destination: Z -> X
  • Destination: Rotation - X: min. 0, max. 90 degrees
  • SPACE: Local Space -> LOCAL SPACE (this one does NOT work, it acts like it is World Space!)

Why? How can I make it act as I set it up?


1 Answer 1


(Vocabulary correction: it's a constraint, not a modifier).

Your constraint setup looks fine, it should work as you want. I recommend you check again the local axes. Especially the bone, since the local axes of a bone do not correspond to the scene like for every other type of object.

First, set your Transform orientation to Local :

enter image description here

Then select your object in object mode, it should show you right away.

For the bone, it's a little bit different. To check a bone's local axes, you have to switch to pose or edit mode first, then select it. (Or enable the axes display option of the armature.)

  • $\begingroup$ Thanks for the vocabulary correction. I checked the local axis and they are right... So that's why I need help. I don't understand why the destination rotation acts like it's in World Space and not Local Space. $\endgroup$ Commented Nov 17, 2018 at 20:52
  • $\begingroup$ Me neither. Maybe you should provide your .blend file so we can watch ourselves. You can use pasteall.org for that and paste the obtained link in your original message (and here as a comment, so that i get notified). $\endgroup$
    – Lauloque
    Commented Nov 17, 2018 at 20:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .