2
$\begingroup$

I have been using Blender for few years on Linux Ubuntu on my Thinkpad and I never faced problem in Blender installation and running smoothly even in my 2 GB ram Linux laptop. Recently, I tried to install blender latest version 2.79 from blender.org in my new Dell xps 15 16 GB ram with Windows 10 pro. I am facing terrible lagging problems,

If I install old version like 2.77 or 2.78 or 2.76 there is problem like I cannot see the tabs anymore. They are so small that I cannot see them.

I cannot understand where is exactly the problem. I have all the pythons installed properly. Can anybody tell me the solution. Is it problem with blender and windows 10 compatibility? I have attached the screen shot, please have a look and tell me the solution.

enter image description here

Just took screen shot of the User Interface in blender 2.78

$\endgroup$
  • $\begingroup$ Please attach a screenshot that shows the problem. $\endgroup$ – dr. Sybren Nov 17 '18 at 9:14
3
$\begingroup$

It's looks like you have retina display, that means it has four real pixels in one digital pixel.

Open File > User Preferences

or CTRL+ALT+U

And the very first entry at the top: Display: Scale

Set it to 2.

enter image description here

$\endgroup$
  • $\begingroup$ Thnaks for your reply. I just installed again blender 2.78 and tried to set the display scale value but I did not get any such option there. Also Dell xps 9570 does not have retina display but intel UHD display. So, is there other options. The problem is if I installed 2.79 latest one O did not get this problem then everything is normal in terms of display. But Then my pc gets hanged. So, I am trying if older version does not have that problem. $\endgroup$ – whoami Nov 17 '18 at 12:44
  • $\begingroup$ Сan you post screenshot with User Preferences? $\endgroup$ – Crantisz Nov 17 '18 at 13:18
  • $\begingroup$ hi, I just added the screen shot of the user interface in blender 2.78. As one can see there is no such option as you mentioned earlier. I think Windows has terrible problem with blender as there are so many problems reported. There should be a manual with blender to reset blender properly after installation to make it compatible with windows. Please suggest a solution. $\endgroup$ – whoami Nov 18 '18 at 0:19
1
$\begingroup$

I am using Blender 2.78. For me to fix this issue, I had to go to the following: File > User Preferences > System > General > DPI DPI setting The DPI had a default value of 72. When I changed this to 144, the UI was way more usable.

New contributor
John Langford is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.