3
$\begingroup$

I was trying different types of materials with Blender, and I tried to play with the glass with Cycles, but in the render, it makes weird blue pixels on my blue table.

Even in the preview tab it makes those :

Preview tab

And in the render, it is horrible :

Beh, it's ugly

This is a simple form ! How could this already fail ?

Thanks in advance for your time !

EDIT 15/11/2018 : A similar question has already been asked at this address, here is the link if you wanted some more intel : Link to the similar question. I would not mark this question as a duplicate because of the "pixels artifacts" keyword, that would guide people like me which search on Google : "dead pixels artifacts". Thanks for sharing this question. Didn't knew these were "fireflies"

$\endgroup$
  • 1
    $\begingroup$ The most basic fix is to turn on Denoising but I also tried running the samples up to 6000 and all the really bright pixels were removed (without denoising). Search blender fireflies to see some of the many ways of reducing these. $\endgroup$ – rob Nov 14 '18 at 15:45
  • $\begingroup$ By marking this a a duplicate it will guide future searchers to the other question. This is exactly why we link duplicates so synonyms all get to the correct answer. $\endgroup$ – David Nov 21 '18 at 3:51
3
$\begingroup$

Those bright pixels you are seeing are Caustics - the stray rays of light that pass through or reflect from a refractive or reflective surface. Given enough samples they will form a meaningful image of the light that passes through your mesh - but they typically require a lot of samples for this - see @bertmoog's answer to Will increasing samples reduce fireflies? for a really good example of different numbers of samples and the effect on the quality of caustics.

An easy way to avoid them is to disable caustics in the Render Light Path settings :

disabling caustics

Another option is to increase the Filter Glossy value on the same panel. This will effectively 'smear out' the single bright dots of caustic to produce more pleasing results with considerably fewer samples - at the expense of the accuracy of the caustics. Interestingly, at Blender version 2.79 this value defaulted to 0.0 (pinpoint caustics) whereas at 2.79.5+ (and 2.8) it defaults to 1.0 which produces a more generally acceptable rendering of caustics 'out of the box'. Adjust the value lower for sharper caustics and higher for rendering with fewer samples.

$\endgroup$
  • $\begingroup$ Indeed, both of the solutions solved the problem of the dead pixels. The render is way better now, by increasing as you said the glossy filter. Like this we keep the light reflection. $\endgroup$ – Bachrc Nov 15 '18 at 17:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.