0
$\begingroup$

I've got a model with mirror, bevel, and subsurf modifiers on it and subsurface is causing some shading issues. I don't know how to fix them other than to just disable it. I've seen another two posts like this but one of them was due to some tris in the corners of the mesh, which I don't think I have.

How do I fix this? enter image description here Here's a download for the .blend file

edit: By request, a screenshot of it without subsurf in edit mode. There are no ngons, it's all quads.enter image description here

$\endgroup$
  • $\begingroup$ It looks like you have ngons in the mesh. Can you post a photo of your mesh in edit mode with subsurf disabled? $\endgroup$ – AshKB Nov 13 '18 at 18:57
  • $\begingroup$ Ashtutosh Budheo, I've added a screenshot in edit mode without the subsurf. I think I've done a fairly good job with the topology, as it's all quads. $\endgroup$ – oyylumo Nov 13 '18 at 23:01
1
$\begingroup$

It looks like the topology automatically generated by the Bevel modifier creates these artifacts, maybe someone will explain. To correct it, you can add some edge loops not too far. Or you can create bevels manually, first horizontally then vertically, it creates a different topology that works better.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.