0
$\begingroup$

I'm trying to align an array of planes to a curve using the curve modifier. However, instead of the planes following the track, they just build a straight line which crosses the starting point of the curve in a 90 degrees angle.

enter image description here

I made sure the plane and curve both have the same origin coordinates, using the Shift+S menu. I tried the "Rotation & Scale" thing in the Ctrl+A menu, made new and simpler curves to try it with, as well as move the curve around. There are countless tutorials for this, but all of those seem to do exactly the same thing as I did and it never worked for me.

Here's my blend file: https://www.mediafire.com/file/gpdf16ubpo3wy7l/plane_curve_issue.blend/file

Thank you!

$\endgroup$
3
$\begingroup$

You ran into 3 gotchas.

  • The transforms on plane and path were not CtrlA applied. The object-level scale was sending deformed planes over the clipping horizon, which I also adjusted. As a general rule, while modeling, scale the mesh in Edit mode, rather than altering the object's transform.
  • The 'Radius' checkbox was set in the path's curve data tab. This means the scale of the deformed plane-array was responding to the curve's radius, which was somewhere near 100. In Edit Mode, under the Transform panel, I selected all the curve's vertices and set the radius to 1.
  • (Maybe not one?) The curve was not closed (cyclic). To toggle that, in Edit Mode, hit AltC

Here's the file..

(BTW, on BSE, this is the preferred (dedicated) site for exchanging .blend files.)

$\endgroup$
  • $\begingroup$ I got it to work with your explanations. Thank you lots! $\endgroup$ – Alfrink Nov 13 '18 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.