0
$\begingroup$

I've been trying to render smoke and fluid simulations, but can't manage to get the results I'm seeking. The first problem is that the smoke and fluid don't simulate. The second problem is that the fluid domain shows up as a solid object in my render. I've tried to solve the issue for hours and I would really appreciate some help! I have appended the .blend file and I hope that someone will be able to take a look at it and help me out.

$\endgroup$
0
$\begingroup$

I'll be focusing on your scene here, however I will also try to generalise a bit so that you can carry the new things over.

Let's start with the fluid simulation - the fluid simulation does simulate in the file you have provided. It pours over the statue.

It does show up like a solid object in the render because you've not added a shader to it, so currently it's just plain old white.

I might have understood that the wrong way, so here's what to do if instead you mean the fact that the domain reverts to a cube during the animation: You've not baked the fluid enough. The process takes a lot of time and can't (to my knowledge) be paused. Hit the "Bake" button located in the physics properties of the fluid domain to bake the fluid cache. This will take up time and space on your harddrive. Blender might be unresponsive during baking - however make sure to save after a bake, as the cache is bound to the save-file. If it crashes and you forgot to save... well, then you can re-bake the whole thing.

If that's not your issue then I'd love to have some clarification as to what's not working out for you.

Onto the smoke simulation! Here is the part where things get a bit more general.

Smoke simulations are hard to calculate for the CPU. The "division" setting for smoke simulations is also not a "quality" slider. There is however a setting called "Smoke High Resolution". I see that you've ticked that one - and at the same time upped the divisions to 100. Blender really didn't like that 100 in the divisions setting. I got a normal result from lowering that setting to 32.

I'd recommend setting the divisions to 32 or 64 and instead increasing the "Divisions" setting under "High Resolution" to increase the quality of the smoke. I'd recommend 2 or 3, anything above 3 will not be worth the additional space on the harddrive and baking times.

A smoke emitter also doesn't need a lot of vertecies - yours currently has about 10000. Replacing it with a simple plane will yield the same result. I've personally not experimented with it, but it might reduce baking times as well.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you for your reply! I haven't been able to work on my scene for quite a while, so I'm sorry for not responding earlier. However, my problem is not yet solved. I've baked my fluid simulation, but when I press the animation player button, I don't see any fluid simulating in my scene. There is no line in the animation player indicating that a cache has been made either. Also, which shader would you suggest for the domain? Should the transparent shader do the trick? $\endgroup$ – maura01 Dec 15 '18 at 16:00
  • $\begingroup$ Don't worry! Admitedly, I'm still confused about your fluid simulation not working out, since it does on my machine. Does this behavior happen with a new file as well, or is it specific to this very project? For the smoke shader, no, a transparent shader will not do. Here Is a great tutorial which got me started on smoke simulations. I'd give the whole thing a watch! $\endgroup$ – IAmGettingTiredOfAliases Dec 16 '18 at 18:02
  • $\begingroup$ Thanks! I fear this is not the only file in which my simulations don't work out. My animation player just doesn't seem to respond, since the cache is bound to the safe-file and does take up memory space. Apparently something has been baked, but I'm unable to play the result... :( $\endgroup$ – maura01 Dec 18 '18 at 14:29
  • $\begingroup$ I basically have the problem talked about in this tutorial: youtube.com/watch?v=9KyVNw3PGnU. Unfortunately the solution presented in the tutorial, doesn't work for me. $\endgroup$ – maura01 Dec 18 '18 at 16:10
  • $\begingroup$ This is leading me to believe that it's caused by something else rather than the simulation. Try changing the loacation of the fluid cache on your harddrive. Since it works for me I'd bring it down to system differences. For me the scene uses about 70 MB of RAM and my harddrives all have at least 5 GB of free space. $\endgroup$ – IAmGettingTiredOfAliases Dec 18 '18 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.