9
$\begingroup$

How do I restrict the influence of a Force Field to the Collection it's in?

I'm trying to simulate falling leaves in Blender 2.8. I have a Collection with the Leafs_Emitter particle system and a Vortex Force Field inside it. I want the Force Field to only affect or influence the falling leaves inside the Collection. But currently, it affects all the other particle systems inside my scene.

Leafs_Emitter Physics tab Force Field

$\endgroup$
2
  • 1
    $\begingroup$ I don't know if it's possible at the moment (not at the computer right now) but there's a workaround: if your other particle systems don't use any vortex-type FFs, you can just set the "Field Weight: Vortex" to 0 for them. (Or you can disable your force field, bake the other systems, then enable it and bake the leaves). $\endgroup$
    – Nicola Sap
    Nov 12, 2018 at 8:55
  • 2
    $\begingroup$ I'm voting to close this question as off-topic because it is about a version of blender still in development. $\endgroup$ Nov 12, 2018 at 13:45

1 Answer 1

11
$\begingroup$

I hope it's not too late for this answer, I just found out how to do it. In the properties of your particle system, at the Field Weights tab, there's an option named Effector Collection, select the collection where your force fields are and that's it. enter image description here

$\endgroup$
2
  • $\begingroup$ Thank you Veronica, it's never too late for an answer! This helped me. $\endgroup$ Oct 23, 2019 at 6:37
  • 2
    $\begingroup$ This is good, but unfortunately doesn't work for Rigid Body. $\endgroup$
    – james_t
    Apr 4, 2021 at 16:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .