Okay so I'm building out my scene and before I know it there's these strange reflections in my floor.

So the way my scene is setup is I have three walls, all of them are the same semi-transparent material and I have light panels shooting through them.

The floor is a cloudy, glossy acrylic-like material and I also have a light shooting from below. Let me know if you have questions. I have my floor settings with the Principled shader below.

enter image description here

enter image description here

Blend file here...

  • $\begingroup$ You could try tweaking the normals a touch on the floor, as in the answer to this question: blender.stackexchange.com/questions/24852/…. Or, maybe try subdividing the floor? Or increase the number of Glossy bounces in the Light Paths rendering settings? $\endgroup$ Commented Nov 10, 2018 at 0:35
  • $\begingroup$ I put the blend file in the post, I can't figure out what's wrong :s $\endgroup$
    – Herdie27
    Commented Nov 14, 2018 at 16:44

1 Answer 1


The problem is due to your wall material - specifically that you are using Subsurface Scattering on a mesh that is non-manifold.

The Subsurface shader (and the Subsurface element of the Principled shader) simulate subsurface scattering based on the surrounding geometry of that mesh - ie, to determine the thickness of the volume enclosed by that mesh and how the light that hits the surrounding surfaces would propagate through that volume before scattering out of the surface again. For this to work properly requires manifold meshes - otherwise you will get unpredictable results.

In your case you have a single-surface plane for the floor and similar for the wall (albeit with ridges for the beams and edges) - ie, these are non-manifold (meaning that they do not fully enclose a single volume in space).

To resolve this you have two options; either change the wall and floor meshes to be manifold panels, or switch to use a Translucent shader in place of Subsurface (which produces a very similar effect).

I amended your example to replace the Principled shader for the walls with a simple Translucent shader and updated the floor with a material made up of a mix between Translucent and Glossy (ideally you'd also include Fresnel for the glossiness but this is grossly simplified) :

floor material

This produces the following result (obviously I'm missing your logo - hence the pink) :

fixed result

Blend file included

Note : To track down issues like this in the future it's best to start from a copy of your file and remove elements bit by bit until you have a very simplified file that contains just those parts that are causing the problem. For example, remove all the lamps, remove the side walls, remove all but one of the 'light panels', remove each material in turn - checking at each stage whether the problem still exists. Once you've tracked it back to a particular material you can substitute each element with a simpler one until you know the exact setting that is causing the problem (in this case the Subsurface setting of the Principled shader). After that it's a matter of determining under what circumstances the issue causes a problem and, hopefully, this should point to a cause.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .