6
$\begingroup$

I used to be able to select and edge loop with AltRMB and then just continue with ShiftAltRMB. But this no longer works in Blender 2.80 and nightly builds of 2.79.

Is there another way to achieve the same?

UPDATE

It's not related to the nightly builds since I am also experiencing the same with the latest official release. Deleting Blender's user preferences doesn't change anything, nor does resetting the keymaps.

So it might be related to the Linux distro I am using (elementary OS), I'll have to look into that and follow up here as soon as I found something.

UPDATE 2

In the meantime, I switched back form elementary OS to Pop!_OS, which resolved the issue. It seems that somehow, elementary OS was blocking the ShiftAltRMB combination. The issue persisted with all versions of Blender, be it 2.79 official, 2.79 nightly or 2.80. Now, all is fine. Even 2.80 works as expected.

UPDATE 3

As of now, Blender 2.80 is using left-click by default for selecting. Selecting edge loops is done by double clicking, which is so much more convenient.

$\endgroup$
2
  • $\begingroup$ maybe you found the solution already but have you tried to double click on the edges or the loop you want to select ? It seems the shortcut changed to just double clicking =) cheers ! $\endgroup$
    – Alcy
    Commented Nov 22, 2018 at 1:36
  • $\begingroup$ @Alcy thanks for the suggestion. In the meantime, I switched back form elementary OS to Pop!_OS, which resolved the issue. It seems that somehow, elementary OS was blocking the Shift + Alt + RMB combination. The issue persisted with all versions of Blender, be it 2.79 official, 2.79 nightly or 2.80. Now, all is fine. Even 2.80 works as expected (with a single click ;) $\endgroup$
    – wout
    Commented Nov 22, 2018 at 8:29

6 Answers 6

6
$\begingroup$

If selecting isn't working with alt-LMB, it's probably because you're using 3 button mouse emulation, in which case the old way of double clicking will work.

I'm still searching how to do edge rings though.

$\endgroup$
1
  • $\begingroup$ thanks this was exactly my problem in this case. $\endgroup$ Commented Apr 26, 2019 at 21:48
4
$\begingroup$

In some reason, OS can think, that you are want to switch keyboard layout and blocks your Alt+Shift combination.

To avoid this, I set "Toggle select" to Loop Select with Alt+RMB, to swap Alt+RMB and Alt+Shift+RMB:

enter image description here

It may require additional deselection with A, but it's better then nothing.

$\endgroup$
3
$\begingroup$

Alt + Double Click with the LMB for me works only this way

UPDATE: no need of Alt

just two quick clicks with LMB

$\endgroup$
1
$\begingroup$

The functionality works fine in both newest builds: Windows 64 bit 2.79 from November 09 2018 02:16:07 and Windows 64 bit 2.8 from November 09 2018 01:37:42.

If it did not work, that would also be perfectly fine since they are experimental. It is your responsibility to experiment with experimental software if you choose to and it is also not very reasonable to ask for help if something does not work, since that is to be expected, because of it being experimental.

With that said, it does not seem that your problem is because of the specific builds you are using in this particular case. I would firstly suspect that something is changed in your keymaps, that can be restored from the User Preferences (Ctrl+Alt+u in Blender 2.79), Input tab:

enter image description here

If that doesn't help, you can try to restore all the default settings and user preferences by deleting your user preferences folder, that is stored at %appdata%\Blender Foundation\Blender\[version number] on Windows. Obviously, you should make a backup before deleting them if you think there is something that you might not want to loose there. That should fix it.

$\endgroup$
2
  • 1
    $\begingroup$ Thank you for the lecture on experimental builds. Your cockiness is not appreciated. Many shortcut changes from 2.80 are also applied to the nightly builds of 2.79, so I see no reason why asking about it here would be out of place, as you suggest. Such a change might as well be intended. That said, I updated my question to reflect your suggestions. $\endgroup$
    – wout
    Commented Nov 10, 2018 at 13:33
  • $\begingroup$ Nightly builds are experimental, 2.79 included. There are clear warnings on the download page. It is harder to help people if they are using software that is constantly changing, which I try to do despite my cockiness. Also the problems with nightly builds might be very temporary, so the answers might not be as useful to this community as good questions about intended Blender's functionality of official releases. Questions about bugs are also considered off topic(see: blender.meta.stackexchange.com/questions/1/…). $\endgroup$ Commented Nov 10, 2018 at 14:48
1
$\begingroup$

I had the same Problem using Elementary OS.

The problem is that the combination Alt + Shift is used to change the keyboard language.

To fix the problem you can go to System Settings -> Keyboard -> Layout Tab and change the Switch Layout option from Alt + Shift to something else.

$\endgroup$
1
  • $\begingroup$ This solution solved the shortcut conflict on my eOS Odin. $\endgroup$
    – zensir
    Commented Dec 12, 2021 at 18:28
0
$\begingroup$

The current way to select edge loops is ALT+LMB and SHIFT+ALT+LMB to add to selection. It used to be double-click, which I think almost everyone liked better. It is unfortunate that it was removed from the beta.

$\endgroup$
1
  • $\begingroup$ I just downloaded the latest build and edge loop selecting is still done with double click. ALT + LMB does nothing with me. :) $\endgroup$
    – wout
    Commented Dec 23, 2018 at 16:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .