-1
$\begingroup$

With the bones parenting with Ctrl+P. Automatic Weight getting this error.

enter image description here

I have 3 bones only. Removed all the doubles. Applied Rotation Scale. All modifiers applied, All mesh are attached. still there is error. Any suggestion. I tried the manifold option from the 3d print addon still did not work.

enter image description here

$\endgroup$
  • $\begingroup$ if you attach the blend file here, someone can take a look at it. $\endgroup$ – Dale Cieslak Nov 7 '18 at 6:16
  • $\begingroup$ Search for non-manifold zones or overlapping geometry, or loose parts. $\endgroup$ – josh sanfelici Nov 7 '18 at 7:04
  • $\begingroup$ @DaleCieslak i have attach the file $\endgroup$ – atek Nov 7 '18 at 7:28
  • $\begingroup$ @Sazerac i have read the answer and i dont think its duplicate. i tried all the option. If so you can go through the file. $\endgroup$ – atek Nov 7 '18 at 7:29
  • $\begingroup$ @joshsanfelici i tried the manifold option from 3d print addon. Still did not work $\endgroup$ – atek Nov 7 '18 at 7:29
0
$\begingroup$

Your mesh is made by different spare parts, which also intersect each other, and this is not what automatic weight is ready to manage.

A workaround can be separating every single piece in one different object (Jacket, legs, pants, ect.), you can do it by selecting all vertices, then press P > Separate by loose parts.

Then you can parent every object to the rig, and later you can join (Ctrl + J) everything in a single mesh as weights are properties of vertices, and they don't change if the meshes are merged.

Anyway I would suggest you to parent your mesh using With empty groups option, then do manual weighting, with paint or direct assign, because with automatic option you will have lots of intersections between various parts of the mesh (and possibly clean some ugly topology and eliminate interiors as far as you can).

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ I have selected the jacket, body, pant & join all the parts with ctrl+J. Or do i have make union with boolean modifier. $\endgroup$ – atek Nov 7 '18 at 13:28
  • $\begingroup$ Ctrl J is ok, boolean would add some more mess. $\endgroup$ – josh sanfelici Nov 7 '18 at 17:03
  • $\begingroup$ @i have done ctrl+j to join had the problem. $\endgroup$ – atek Nov 8 '18 at 1:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.